qt4-tools-sdk: Use an install target to install the qt4 utilities
authorHolger Hans Peter Freyther <zecke@selfish.org>
Sun, 9 Aug 2009 04:20:34 +0000 (06:20 +0200)
committerHolger Hans Peter Freyther <zecke@selfish.org>
Sun, 9 Aug 2009 04:20:34 +0000 (06:20 +0200)
recipes/qt4/qt4-tools-sdk_4.5.2.bb

index fafb771..c0f2f7a 100644 (file)
@@ -61,12 +61,11 @@ do_compile() {
     done
 }
 
-do_stage() {
-    install -d ${STAGING_BINDIR_NATIVE}/
-    install -m 0755 bin/qmake ${STAGING_BINDIR_NATIVE}/qmake2
+do_install() {
+    install -d ${D}${bindir}
+    install -m 0755 bin/qmake ${D}${bindir}/qmake2
     for i in moc uic uic3 rcc lrelease lupdate qdbuscpp2xml qdbusxml2cpp; do
-        install -m 0755 bin/${i} ${STAGING_BINDIR_NATIVE}/${i}4
+        install -m 0755 bin/${i} ${D}${bindir}/${i}4
     done
 }
 
-