ppp: make if-up/-down scripts compatible to resolvconf (thx to Wonka)
authorThomas Zimmermann <ml@vdm-design.de>
Sat, 27 Mar 2010 16:28:08 +0000 (17:28 +0100)
committerThomas Zimmermann <ml@vdm-design.de>
Sat, 27 Mar 2010 16:28:08 +0000 (17:28 +0100)
Signed-off-by: Thomas Zimmermann <ml@vdm-design.de>
recipes/ppp/files/08setupdns
recipes/ppp/files/92removedns
recipes/ppp/ppp_2.4.3.bb

index 998219d..5be2d38 100644 (file)
@@ -1,7 +1,9 @@
 #!/bin/sh
 ACTUALCONF=/var/run/resolv.conf
 PPPCONF=/var/run/ppp/resolv.conf
-if [ -f $PPPCONF ] ; then
+if [ -x /sbin/resolvconf ] ; then
+       cat $PPPCONF | resolvconf -a $PPP_IFACE
+elif [ -f $PPPCONF ] ; then
        if [ -f $ACTUALCONF ] ; then
                if [ ! -h $ACTUALCONF -o ! "`readlink $ACTUALCONF 2>&1`" = "$PPPCONF" ] ; then
                        mv $ACTUALCONF $ACTUALCONF.ppporig
index 2eadec6..aa3304d 100644 (file)
@@ -1,5 +1,7 @@
 #!/bin/sh
 ACTUALCONF=/var/run/resolv.conf
-if [ -f $ACTUALCONF.ppporig ] ; then
+if [ -x /sbin/resolvconf ] ; then
+       resolvconf -d $PPP_IFACE
+elif [ -f $ACTUALCONF.ppporig ] ; then
        mv $ACTUALCONF.ppporig $ACTUALCONF
 fi
index 3b1f8ad..4c7b168 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "Point-to-Point Protocol (PPP) daemon"
 HOMEPAGE = "http://samba.org/ppp/"
 DEPENDS = "libpcap"
 LICENSE = "BSD GPLv2"
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "http://ppp.samba.org/ftp/ppp/ppp-${PV}.tar.gz \
         file://ppp-2.4.3-mppe-mppc-1.1.patch;patch=1 \