- split up hostap-modules package into hostap-modules, hostap-modules-cs, and hostap...
authorMichael Lauer <mickey@vanille-media.de>
Wed, 11 Aug 2004 10:09:07 +0000 (10:09 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Wed, 11 Aug 2004 10:09:07 +0000 (10:09 +0000)
- adjust machine configurations to RDEPEND on hostap-modules-cs.

BKrev: 4119f043tj69uFyok2N7HpTooC3AQA

conf/beagle.conf
conf/collie.conf
conf/ipaq-common.conf
conf/poodle.conf
conf/simpad.conf
conf/zaurus-pxa.conf
hostap/hostap-modules-0.2.4/mtx_compat.diff [new file with mode: 0644]
hostap/hostap-modules-0.2.4/mtx_hostap_deferred_irq.diff [new file with mode: 0644]
hostap/hostap-modules_0.2.4.oe

index ee09262..db22f07 100644 (file)
@@ -7,7 +7,7 @@ IPKG_ARCHS = "all arm ${MACHINE}"
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "montavista-sa"
 BOOTSTRAP_EXTRA_DEPENDS = "virtual/kernel modutils-collateral hostap-modules orinoco-modules"
-BOOTSTRAP_EXTRA_RDEPENDS = "kernel modutils-collateral hostap-modules orinoco-modules \
+BOOTSTRAP_EXTRA_RDEPENDS = "kernel modutils-collateral hostap-modules-cs orinoco-modules \
 kernel-module-net-fd \
 kernel-module-sa1100-bi kernel-module-usbdcore kernel-module-usbdmonitor " 
 
index 22007a6..86e30d8 100644 (file)
@@ -7,7 +7,7 @@ IPKG_ARCHS = "all arm ${MACHINE}"
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "openzaurus-sa"
 BOOTSTRAP_EXTRA_DEPENDS = "virtual/kernel hostap-modules orinoco-modules sharp-sdmmc-support"
-BOOTSTRAP_EXTRA_RDEPENDS = "kernel modutils hostap-modules orinoco-modules sharp-sdmmc-support \
+BOOTSTRAP_EXTRA_RDEPENDS = "kernel modutils hostap-modules-cs orinoco-modules sharp-sdmmc-support \
 kernel-module-devinfo kernel-module-gpio kernel-module-net-fd kernel-module-registers kernel-module-sa1100-bi \
 kernel-module-usbdcore kernel-module-usbdmonitor " 
 
index 150128e..f7c044a 100644 (file)
@@ -1,4 +1,4 @@
 IPAQ_MODULES = "apm h3600_generic_sleeve ipaq-sleeve ipaq-mtd-asset nvrd pcmf502rd pcmf502re sa1100-rtc ipaq-hal h3600_ts" 
 
 BOOTSTRAP_EXTRA_DEPENDS += "hostap-modules orinoco-modules freeswan mipv6"
-BOOTSTRAP_EXTRA_RRECOMMENDS += "hostap-modules orinoco-modules freeswan mipv6 ${@linux_module_packages('${IPAQ_MODULES}')}"
+BOOTSTRAP_EXTRA_RRECOMMENDS += "hostap-modules-cs orinoco-modules freeswan mipv6 ${@linux_module_packages('${IPAQ_MODULES}')}"
index b8cc3df..8c072bf 100644 (file)
@@ -7,7 +7,7 @@ IPKG_ARCHS = "all arm ${MACHINE}"
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "openzaurus-pxa"
 BOOTSTRAP_EXTRA_DEPENDS = "virtual/kernel modutils-collateral hostap-modules orinoco-modules sharp-sdmmc-support"
-BOOTSTRAP_EXTRA_RDEPENDS = "kernel hostap-modules orinoco-modules sharp-sdmmc-support \
+BOOTSTRAP_EXTRA_RDEPENDS = "kernel hostap-modules-cs orinoco-modules sharp-sdmmc-support \
 kernel-module-ip-gre  \
 kernel-module-ipip kernel-module-irnet kernel-module-net-fd kernel-module-registers kernel-module-pxa-bi \
 kernel-module-usbdcore kernel-module-usbdmonitor modutils-collateral"
index 0279c85..ab4c66f 100644 (file)
@@ -8,7 +8,7 @@ PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "opensimpad-64+0"
 BOOTSTRAP_EXTRA_DEPENDS = "virtual/kernel hostap-modules orinoco-modules freeswan mipv6 atmelwlandriver"
 BOOTSTRAP_EXTRA_RDEPENDS = "kernel"
-BOOTSTRAP_EXTRA_RRECOMMENDS = "freeswan mipv6 hostap-modules orinoco-modules atmelwlandriver kernel-module-sa1100-ir"
+BOOTSTRAP_EXTRA_RRECOMMENDS = "freeswan mipv6 hostap-modules-cs orinoco-modules atmelwlandriver kernel-module-sa1100-ir"
 EXTRA_IMAGECMD_jffs2 = "--pad --little-endian --eraseblock=0x20000 -n"
 EXTRA_IMAGEDEPENDS = ""
 INHERIT += "simpad_flashimg"
index a58107a..0fdb294 100644 (file)
@@ -3,7 +3,7 @@ IPKG_ARCHS = "all arm ${MACHINE}"
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "openzaurus-pxa"
 BOOTSTRAP_EXTRA_DEPENDS = "virtual/kernel hostap-modules orinoco-modules sharp-sdmmc-support chkhinge"
-BOOTSTRAP_EXTRA_RDEPENDS = "kernel hostap-modules orinoco-modules sharp-sdmmc-support \
+BOOTSTRAP_EXTRA_RDEPENDS = "kernel hostap-modules-cs orinoco-modules sharp-sdmmc-support \
 kernel-module-net-fd kernel-module-registers kernel-module-pxa-bi \
 kernel-module-usbdcore kernel-module-usbdmonitor modutils chkhinge"
 
diff --git a/hostap/hostap-modules-0.2.4/mtx_compat.diff b/hostap/hostap-modules-0.2.4/mtx_compat.diff
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/hostap/hostap-modules-0.2.4/mtx_hostap_deferred_irq.diff b/hostap/hostap-modules-0.2.4/mtx_hostap_deferred_irq.diff
new file mode 100644 (file)
index 0000000..e69de29
index 04d1817..9925ce7 100644 (file)
@@ -8,14 +8,18 @@ PR = "r1"
 SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
            file://hostap_cs.conf \
           file://Makefile.patch;patch=1"
+SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
+       file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
+
 S = "${WORKDIR}/hostap-driver-${PV}"
 
 inherit module
 
 # Hack Alert :D
+ARCH_mipsel = "mips"
 MAKE_TARGETS = "KERNEL_PATH=${KERNEL_SOURCE} MAKE='make -e'"
 
-NET_MODULES = "hostap.o hostap_crypt_ccmp.o hostap_crypt_tkip.o hostap_crypt_wep.o"
+NET_MODULES = "hostap.o hostap_pci.o hostap_crypt_ccmp.o hostap_crypt_tkip.o hostap_crypt_wep.o"
 
 do_install() {
        install -d ${D}/lib/modules/${KERNEL_VERSION}/net \
@@ -29,3 +33,10 @@ do_install() {
        install -m 0644 driver/etc/hostap_cs.conf ${D}/${sysconfdir}/pcmcia/hostap_cs.conf
        cat ${WORKDIR}/hostap_cs.conf >>${D}/${sysconfdir}/pcmcia/hostap_cs.conf
 }
+
+PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
+FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/"
+FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci.o"
+FILES_hostap-modules = "/lib/modules/"
+RDEPENDS_hostap-modules-cs = "hostap-modules"
+RDEPENDS_hostap-modules-pci = "hostap-modules"