xorg-xserver: XRandR version fix 06c06f6 ported to all old X servers.
authorStanislav Brabec <utx@penguin.cz>
Tue, 6 Oct 2009 20:45:37 +0000 (20:45 +0000)
committerutx@penguin.cz <utx@penguin.cz>
Tue, 6 Oct 2009 20:45:37 +0000 (20:45 +0000)
recipes/xorg-xserver/files/report-correct-randr10.patch [new file with mode: 0644]
recipes/xorg-xserver/xserver-kdrive-imageon_1.2.0.bb
recipes/xorg-xserver/xserver-kdrive-xomap_1.1.99.3.bb
recipes/xorg-xserver/xserver-kdrive_1.1.0.bb
recipes/xorg-xserver/xserver-kdrive_1.2.0.bb
recipes/xorg-xserver/xserver-xorg_1.2.0.bb
recipes/xorg-xserver/xserver-xorg_1.3.0.0.bb

diff --git a/recipes/xorg-xserver/files/report-correct-randr10.patch b/recipes/xorg-xserver/files/report-correct-randr10.patch
new file mode 100644 (file)
index 0000000..540f598
--- /dev/null
@@ -0,0 +1,25 @@
+Index: xorg-server-1.1.0/randr/randr.c
+===================================================================
+--- xorg-server-1.1.0.orig/randr/randr.c
++++ xorg-server-1.1.0/randr/randr.c
+@@ -56,6 +56,9 @@
+ #define SubPixelUnknown 0
+ #endif
++#define SERVER_RANDR_MAJOR    1
++#define SERVER_RANDR_MINOR    0
++
+ #define RR_VALIDATE
+ int   RRGeneration;
+ int   RRNScreens;
+@@ -473,8 +476,8 @@ ProcRRQueryVersion (ClientPtr client)
+     rep.type = X_Reply;
+     rep.length = 0;
+     rep.sequenceNumber = client->sequence;
+-    rep.majorVersion = RANDR_MAJOR;
+-    rep.minorVersion = RANDR_MINOR;
++    rep.majorVersion = SERVER_RANDR_MAJOR;
++    rep.minorVersion = SERVER_RANDR_MINOR;
+     if (client->swapped) {
+       swaps(&rep.sequenceNumber, n);
+       swapl(&rep.length, n);
index 18b85fd..27a08d2 100644 (file)
@@ -7,7 +7,7 @@ DEPENDS += "libxkbfile libxcalibrate"
 PROVIDES = "virtual/xserver"
 
 PE = "1"
-PR = "r7"
+PR = "r8"
 
 FILESPATH = "${FILE_DIRNAME}/xserver-kdrive-${PV}:${FILE_DIRNAME}/xserver-kdrive:${FILE_DIRNAME}/files"
 SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
@@ -23,6 +23,7 @@ SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
         file://enable-builtin-fonts.patch;patch=1 \
        file://fix-picturestr-include-order.patch;patch=1 \
        file://split_multiple_AC_SUBST.patch;patch=1 \
+       file://report-correct-randr10.patch;patch=1 \
        "
        
 S = "${WORKDIR}/xorg-server-${PV}"
index 57f7050..5994bc0 100644 (file)
@@ -7,7 +7,7 @@ SECTION = "x11/base"
 DESCRIPTION = "X server from freedesktop.org"
 DESCRIPTION_xserver-kdrive-xomap = "X server for the OMAP in the Nokia 800"
 
-PR = "r2"
+PR = "r3"
 PE = "1"
 
 COMPATIBLE_MACHINE = "nokia(800|770)"
@@ -25,7 +25,8 @@ SRC_URI = "http://repository.maemo.org/pool/maemo3.1/free/source/xorg-server_1.1
        file://button_only.patch;patch=1 \
        file://calibrateext.patch;patch=1 \
         file://fix-picturestr-include-order.patch;patch=1 \
-       file://xcalibrate_coords.patch;patch=1"
+       file://xcalibrate_coords.patch;patch=1 \
+       file://report-correct-randr10.patch;patch=1"
 #      file://kdrive-evdev.patch;patch=1  \
 #      file://kdrive-use-evdev.patch;patch=1  \
 #      file://optional-xkb.patch;patch=1 \
index be6fc82..8157054 100644 (file)
@@ -10,7 +10,7 @@ DESCRIPTION_xserver-kdrive-fake = "Fake X server"
 DESCRIPTION_xserver-kdrive-xephyr = "X server in an X window"
 
 PE = "1"
-PR = "r1"
+PR = "r2"
 
 FILES_${PN} = "${libdir}/xserver"
 FILES_xserver-kdrive-fbdev = "${bindir}/Xfbdev"
@@ -34,7 +34,8 @@ SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-1.1.0.tar.bz2 \
        file://enable-tslib.patch;patch=1 \
        file://xcalibrate.patch;patch=1 \
        file://xfbdev-fb-opt.patch;patch=1 \
-       file://hide-cursor-and-ppm-root.patch;patch=1"
+       file://hide-cursor-and-ppm-root.patch;patch=1 \
+       file://report-correct-randr10.patch;patch=1"
 
 SRC_URI_append_mnci   = " file://onlyfb.patch;patch=1"
 SRC_URI_append_poodle = " file://xserver-kdrive-poodle.patch;patch=1"
index e1b898e..fd2f1f3 100644 (file)
@@ -3,7 +3,7 @@ require xserver-kdrive-common.inc
 DEPENDS += "libxkbfile libxcalibrate"
 
 PE = "1"
-PR = "r10"
+PR = "r11"
 
 SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
        ${KDRIVE_COMMON_PATCHES} \
@@ -18,6 +18,7 @@ SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
         file://w100-fix-offscreen-bmp.patch;patch=1 \
         file://fbcompositesrc8888revnpx0565.patch;patch=1 \
         file://xcalibrate_coords.patch;patch=1 \
+       file://report-correct-randr10.patch;patch=1 \
        "
        
 S = "${WORKDIR}/xorg-server-${PV}"
index 50d182c..fd52dba 100644 (file)
@@ -2,10 +2,12 @@ MESA_VER = "6.5.2"
 
 require xorg-xserver-common.inc
 PE = "1"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
 
 export LDFLAGS += " -ldl "
 
 #DESCRIPTION = ""
 
 #DEPENDS += " "
+
+SRC_URI += "file://report-correct-randr10.patch;patch=1"
\ No newline at end of file
index 1efea75..fc9eac0 100644 (file)
@@ -2,10 +2,11 @@ MESA_VER = "6.5.2"
 
 require xorg-xserver-common.inc
 PE = "1"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
 
 SRC_URI += "file://drmfix.patch;patch=1 \
-            file://glyphstr.patch;patch=1"
+            file://glyphstr.patch;patch=1 \
+            file://report-correct-randr12.patch;patch=1"
 
 export LDFLAGS += " -ldl "