bcel 5.2: New recipe (from Jalimo SVN).
authorRobert Schuster <robertschuster@fsfe.org>
Fri, 18 Sep 2009 11:53:07 +0000 (13:53 +0200)
committerRobert Schuster <robertschuster@fsfe.org>
Fri, 18 Sep 2009 11:53:07 +0000 (13:53 +0200)
bcel-native 5.2: Dito.

recipes/bcel/bcel-native_5.2.bb [new file with mode: 0644]
recipes/bcel/bcel_5.2.bb [new file with mode: 0644]

diff --git a/recipes/bcel/bcel-native_5.2.bb b/recipes/bcel/bcel-native_5.2.bb
new file mode 100644 (file)
index 0000000..478b770
--- /dev/null
@@ -0,0 +1,6 @@
+require bcel_${PV}.bb
+
+inherit java-native
+
+DEPENDS = "fastjar-native xerces-j-native regexp-native"
+
diff --git a/recipes/bcel/bcel_5.2.bb b/recipes/bcel/bcel_5.2.bb
new file mode 100644 (file)
index 0000000..faf6043
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "Java Bytecode manipulation library"
+LICENSE = "AL2.0"
+AUTHOR = "Apache Software Foundation"
+
+SRC_URI = "http://archive.apache.org/dist/jakarta/bcel/source/${BP}-src.tar.gz"
+
+inherit java-library
+
+DEPENDS = "fastjar-native xerces-j regexp"
+
+do_compile() {
+  mkdir -p build
+
+  oe_makeclasspath cp -s xercesImpl regexp
+
+  javac -sourcepath src/java -d build -cp $cp `find src/java -name \*.java`
+
+  fastjar -C build -c -f ${JARFILENAME} .
+}