fuse-exfat: add from current openembedded-core
authorGrazvydas Ignotas <notasas@gmail.com>
Sat, 15 Aug 2015 14:04:42 +0000 (17:04 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Sat, 15 Aug 2015 14:04:42 +0000 (17:04 +0300)
classes/scons.bbclass
recipes/fuse-exfat/fuse-exfat_1.1.0.bb [new file with mode: 0644]

index 2a935e4..1dbce0d 100644 (file)
@@ -1,6 +1,7 @@
 DEPENDS += "python-scons-native"
 
 export TARGET_LINK_HASH_STYLE
+EXTRA_OESCONS ?= ""
 
 scons_do_compile() {
     if [ "${SCONS_FIX_ENV}" = "1" ] ; then
@@ -11,14 +12,13 @@ scons_do_compile() {
         fi
     fi
 
-    ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} CXX="${CXX}" PREFIX=${prefix} prefix=${prefix} || \
-    oefatal "scons build execution failed."
+        ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} PREFIX=${prefix} prefix=${prefix} ${EXTRA_OESCONS} || \
+        die "scons build execution failed."
 }
 
 scons_do_install() {
-       install -d ${D}${prefix}
-        ${STAGING_BINDIR_NATIVE}/scons PREFIX=${D}${prefix} prefix=${D}${prefix} install || \
-        oefatal "scons install execution failed."
+        ${STAGING_BINDIR_NATIVE}/scons PREFIX=${D}${prefix} prefix=${D}${prefix} install ${EXTRA_OESCONS}|| \
+        die "scons install execution failed."
 }
 
 EXPORT_FUNCTIONS do_compile do_install
diff --git a/recipes/fuse-exfat/fuse-exfat_1.1.0.bb b/recipes/fuse-exfat/fuse-exfat_1.1.0.bb
new file mode 100644 (file)
index 0000000..6a83ab2
--- /dev/null
@@ -0,0 +1,26 @@
+SUMMARY = "read and write exFAT driver for FUSE"
+DESCRIPTION = "fuse-exfat is a read and write driver implementing the \
+extended file allocation table as a filesystem in userspace. A mounthelper \
+is provided under the name mount.exfat-fuse. \
+"
+HOMEPAGE = "http://code.google.com/p/exfat/"
+SECTION = "universe/otherosfs"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+SRC_URI = "${DEBIAN_MIRROR}/main/f/fuse-exfat/fuse-exfat_${PV}.orig.tar.gz \
+"
+DEPENDS = "fuse virtual/libc"
+RRECOMMENDS_${PN} = "util-linux-mount"
+
+inherit scons
+
+SRC_URI[md5sum] = "b2a23c032661cb1c1da4514e7af33916"
+SRC_URI[sha256sum] = "198c520e417e955dc5c08687c278e63eefa56719da4452aa4a605be0327f953e"
+
+EXTRA_OESCONS = " \
+    CCFLAGS='${CCFLAGS} -std=c99' DESTDIR=${D}/${base_sbindir} \
+"
+
+do_install_prepend() {
+    install -d ${D}/${base_sbindir}
+}