embedix kernels: set COMPATIBLE_MACHINE = "none"
authorAndrea Adami <andrea.adami@gmail.com>
Wed, 24 Jun 2009 23:56:07 +0000 (01:56 +0200)
committerAndrea Adami <andrea.adami@gmail.com>
Thu, 25 Jun 2009 00:03:14 +0000 (02:03 +0200)
 - silence the notes like:
 - ERROR: '[]' RDEPENDS/RRECOMMENDS or otherwise
 - requires the runtime entity 'virtual/arm-angstrom-linux-gcc-2.95'
 - but it wasn't found in any PACKAGE or RPROVIDES variables
- COMPATIBLE_MACHINE is set in sharprom-compatible

conf/distro/sharprom-compatible.conf
recipes/linux/collie-kernels-2.4-embedix.bb
recipes/linux/openzaurus-pxa27x_2.4.20-rmk2-embedix20050602.bb
recipes/linux/openzaurus-pxa_2.4.18-rmk7-pxa3-embedix20031107.inc
recipes/linux/openzaurus-sa_2.4.18-rmk7-pxa3-embedix20030509.bb

index 93077e1..81f919b 100644 (file)
@@ -25,6 +25,12 @@ export TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}/${layout_includedir}"
 #DEBUG_OPTIMIZATION = "-O -g3"
 #DEBUG_BUILD = "1"
 
+# We are still using 2.4 embedix kernels
+COMPATIBLE_MACHINE_pn-openzaurus-pxa27x = "(akita|spitz)"
+COMPATIBLE_MACHINE_pn-openzaurus-pxa = "(c7x0|poodle|poodle255|tosa)"
+COMPATIBLE_MACHINE_pn-collie-kernels = "collie"
+COMPATIBLE_MACHINE_pn-openzaurus-sa = "collie"
+
 #
 # Base
 #
index b7dfa37..1445e41 100644 (file)
@@ -5,7 +5,11 @@ PROVIDES = "virtual/kernel"
 PR = "r2"
 
 COMPATIBLE_HOST = "arm.*-linux"
-COMPATIBLE_MACHINE = "collie"
+
+# For these old 2.4 kernels we override in sharprom-compatible.conf
+#COMPATIBLE_MACHINE = "collie"
+COMPATIBLE_MACHINE = "none"
+
 
 DEPENDS = '${@base_conditional("DISTRO_TYPE", "debug", "openzaurus-sa", "collie-kernel-64-0 collie-kernel-24-8 collie-kernel-32-0 collie-kernel-32-32 collie-kernel-40-24 collie-kernel-48-16 collie-kernel-58-6",d)}'
 PACKAGES = ""
index 5a90d41..e65f293 100644 (file)
@@ -5,7 +5,6 @@ PV = "2.4.20-rmk2-embedix"
 LICENSE = "GPL"
 KV = "2.4.20"
 PR = "r18"
-COMPATIBLE_MACHINE = "(akita|spitz)"
 
 SRC_URI = "http://developer.ezaurus.com/sl_j/source/c3100/20050602/linux-c3100-20050602-rom1_01.tar.bz2 \
            file://P01-C3000-clockup_050221.patch;pnum=2;patch=1 \
@@ -76,7 +75,11 @@ EXTRA_OEMAKE = "OPENZAURUS_RELEASE=-${DISTRO_VERSION}"
 KERNEL_CCSUFFIX = "-2.95"
 KERNEL_LDSUFFIX = "-2.11.2"
 COMPATIBLE_HOST = "arm.*-linux"
-COMPATIBLE_MACHINE = '(akita|spitz|borzoi)'
+
+# For these old 2.4 kernels we override in sharprom-compatible.conf
+#COMPATIBLE_MACHINE = "(akita|spitz|borzoi)"
+COMPATIBLE_MACHINE = "none"
+
 PARALLEL_MAKE = ""
 
 #
index 7b20b4f..6428629 100644 (file)
@@ -7,7 +7,6 @@ KV = "2.4.18"
 RMKV = "7"
 PXAV = "3"
 SHARPV = "20031107"
-COMPATIBLE_MACHINE = "(poodle|corgi|shepherd|husky|poodle255|tosa)"
 
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/openzaurus-pxa-${KV}-rmk${RMKV}-pxa${PXAV}-embedix${SHARPV}"
 
@@ -89,7 +88,11 @@ EXTRA_OEMAKE = " EMBEDIXRELEASE=-${DISTRO_VERSION}"
 KERNEL_CCSUFFIX = "-2.95"
 KERNEL_LDSUFFIX = "-2.11.2"
 COMPATIBLE_HOST = "arm.*-linux"
-COMPATIBLE_MACHINE = '(corgi|husky|shepherd|poodle|poodle255)'
+
+# For these old 2.4 kernels we override in sharprom-compatible.conf
+#COMPATIBLE_MACHINE = "(poodle|corgi|shepherd|husky|poodle255|tosa)"
+COMPATIBLE_MACHINE = "none"
+
 PARALLEL_MAKE = ""
 
 #
index b21a0c9..4c9e9a1 100644 (file)
@@ -8,7 +8,6 @@ PXAV = "3"
 SHARPV = "20030509"
 PR = "r23"
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/openzaurus-sa-${KV}-rmk${RMKV}-pxa${PXAV}-embedix${SHARPV}"
-COMPATIBLE_MACHINE = "collie"
 
 SRC_URI = "http://www.openzaurus.org/mirror/linux-sl5500-${SHARPV}-rom3_10.tar.bz2 \
            file://cacko.patch;patch=1 \
@@ -58,7 +57,11 @@ ALLOW_EMPTY = "1"
 KERNEL_CCSUFFIX = "-2.95"
 KERNEL_LDSUFFIX = "-2.11.2"
 COMPATIBLE_HOST = "arm.*-linux"
-COMPATIBLE_MACHINE = "collie"
+
+# For these old 2.4 kernels we override in sharprom-compatible.conf
+#COMPATIBLE_MACHINE = "collie"
+COMPATIBLE_MACHINE = "none"
+
 EXTRA_OEMAKE = " EMBEDIXRELEASE=-${DISTRO_VERSION}"
 
 module_conf_usbdmonitor = "alias usbd0 usbdmonitor"