gnome-panel: add 2.30.0
authorKoen Kooi <koen@openembedded.org>
Thu, 1 Apr 2010 11:47:55 +0000 (13:47 +0200)
committerKoen Kooi <koen@openembedded.org>
Thu, 1 Apr 2010 12:04:14 +0000 (14:04 +0200)
recipes/gnome/gnome-panel-2.30.0/idl-sysroot.patch [new file with mode: 0644]
recipes/gnome/gnome-panel_2.30.0.bb [new file with mode: 0644]

diff --git a/recipes/gnome/gnome-panel-2.30.0/idl-sysroot.patch b/recipes/gnome/gnome-panel-2.30.0/idl-sysroot.patch
new file mode 100644 (file)
index 0000000..de4cd84
--- /dev/null
@@ -0,0 +1,22 @@
+--- /tmp/Makefile.am   2009-10-26 16:53:20.000000000 +0100
++++ gnome-panel-2.28.0/gnome-panel/Makefile.am 2009-10-26 16:53:51.000000000 +0100
+@@ -43,7 +43,7 @@
+       $(NULL)
+ $(CORBA_SRCLIST): $(top_srcdir)/idl/GNOME_Panel.idl $(ORBIT_IDL)
+-      $(AM_V_GEN)$(ORBIT_IDL) -I $(BONOBO_IDLDIR) -I $(BONOBO_ACT_IDLDIR) $(top_srcdir)/idl/GNOME_Panel.idl
++      $(AM_V_GEN)$(ORBIT_IDL) -I $(SYSROOT)$(BONOBO_IDLDIR) -I $(SYSROOT)$(BONOBO_ACT_IDLDIR) $(top_srcdir)/idl/GNOME_Panel.idl
+ BUILT_SOURCES = \
+       $(CORBA_SRCLIST)        \
+--- /tmp/Makefile.am   2009-10-26 16:54:17.000000000 +0100
++++ gnome-panel-2.28.0/libpanel-applet/Makefile.am     2009-10-26 16:54:34.000000000 +0100
+@@ -45,7 +45,7 @@
+       GNOME_Panel.h
+ $(CORBA_SRCLIST): $(top_srcdir)/idl/GNOME_Panel.idl $(ORBIT_IDL)
+-      $(AM_V_GEN)$(ORBIT_IDL) -I $(BONOBO_IDLDIR) -I $(BONOBO_ACT_IDLDIR) $(top_srcdir)/idl/GNOME_Panel.idl
++      $(AM_V_GEN)$(ORBIT_IDL) -I $(SYSROOT)$(BONOBO_IDLDIR) -I $(SYSROOT)$(BONOBO_ACT_IDLDIR) $(top_srcdir)/idl/GNOME_Panel.idl
+ noinst_PROGRAMS = test-bonobo-applet
diff --git a/recipes/gnome/gnome-panel_2.30.0.bb b/recipes/gnome/gnome-panel_2.30.0.bb
new file mode 100644 (file)
index 0000000..ecbc2bd
--- /dev/null
@@ -0,0 +1,38 @@
+DESCRIPTION = "GNOME panel"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = "gconf librsvg libgweather startup-notification libwnck orbit2 gtk+ libbonoboui libglade libgnome libgnomeui gnome-desktop libglade gnome-menus orbit2-native"
+
+inherit gnome pkgconfig
+
+SRC_URI += "file://idl-sysroot.patch;patch=1"
+
+SRC_URI[archive.md5sum] = "e17f25417b2c9011ed1c3ebd75706de6"
+SRC_URI[archive.sha256sum] = "7e8f99d3105bc0dda038b5859ab56d0a9740e244d7853786f1deb2df0a692220"
+
+CPPFLAGS += " -I${STAGING_INCDIR}/gnome-desktop-2.0" 
+export SYSROOT = "${STAGING_DIR_HOST}"
+
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2 SYSROOT=${SYSROOT}"
+EXTRA_OECONF = "--disable-scrollkeeper --disable-eds"
+
+do_configure_prepend() {
+        sed -i -e s:help:: ${S}/Makefile.am
+}
+
+pkg_postinst_append () {
+       gconftool-2 --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults \
+               --direct --load /etc/gconf/schemas/panel-default-setup.entries
+}
+
+PACKAGES =+ "libpanel-applet"
+FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
+
+FILES_${PN} =+ "${datadir}/gnome* \
+                ${datadir}/dbus-1 \
+                ${datadir}/icons \
+                ${datadir}/PolicyKit \
+                ${libdir}/bonobo \
+               "
+
+