dbus: fix dbus-daemon segfault on mipsel with recent toolchain
authorGraham Gower <graham.gower@gmail.com>
Thu, 6 Aug 2009 15:26:21 +0000 (15:26 +0000)
committerHolger Hans Peter Freyther <zecke@selfish.org>
Wed, 12 Aug 2009 03:24:29 +0000 (05:24 +0200)
dbus-daemon segfaults on mipsel when built with -fPIE/-pie, as outlined in
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=532821

Removes PIE compilation from the dbus-daemon Makefile as a workaround.

Signed-off-by: Graham Gower <graham.gower@gmail.com>
Acked-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Holger Freyther <zecke@selfish.org>
recipes/dbus/dbus-native_1.0.3.bb
recipes/dbus/dbus-native_1.2.1.bb
recipes/dbus/dbus.inc
recipes/dbus/dbus_1.0.3.bb
recipes/dbus/dbus_1.2.1.bb

index 8a4c6fe..6ec0fc8 100644 (file)
@@ -1,6 +1,6 @@
 require dbus.inc
 
-PR = "r1"
+PR = "${INC_PR}.0"
 DEFAULT_PREFERENCE = "-1"
 
 inherit native
index 566c7bc..2b1610e 100644 (file)
@@ -1,4 +1,5 @@
 require dbus.inc
+PR = "${INC_PR}.0"
 RRECOMMENDS_${PN} = ""
 RDEPENDS_${PN} = ""
 inherit native
index 0302cfe..b5eeb08 100644 (file)
@@ -4,6 +4,8 @@ SECTION = "base"
 LICENSE = "GPL"
 DEPENDS = "expat glib-2.0 virtual/libintl libsm libice virtual/libx11"
 
+INC_PR = "r16"
+
 SRC_URI = "\
   http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
   file://cross.patch;patch=1 \
@@ -30,6 +32,10 @@ EXTRA_OECONF = "\
   --with-dbus-default-reply-timeout=200000 \
 "
 
+do_compile_prepend_mipsel() {
+       sed -i -e 's/\-fPIE//' -e 's/\-pie\ \-Wl\,\-z\,relro//' bus/Makefile
+}
+
 do_install_append() {
         install -d ${D}${sysconfdir}/init.d
         install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1
index 2589cfe..7001bb9 100644 (file)
@@ -1,4 +1,4 @@
 require dbus.inc
-PR = "r16"
+PR = "${INC_PR}.0"
 
 DEFAULT_PREFERENCE = "-1"
index 9d6c4c1..72db1da 100644 (file)
@@ -1,3 +1,3 @@
 include dbus.inc
 
-PR = "r12"
+PR = "${INC_PR}.0"