icu: Fix class ordering problem by converting to use SYSROOT_PREPROCESS_FUNCS
authorRichard Purdie <rpurdie@linux.intel.com>
Wed, 11 Nov 2009 21:38:33 +0000 (21:38 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 11 Nov 2009 21:38:33 +0000 (21:38 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
recipes/icu/icu_3.6.bb

index 3eccfb5..ae79ce7 100644 (file)
@@ -37,8 +37,10 @@ do_stage() {
         autotools_stage_all
 }
 
-# We need to append this so it runs *after* binconfig.do_stage
-do_stage_append() {
+SYSROOT_PREPROCESS_FUNCS += "icu_sysroot_preprocess"
+
+# We need to append this so it runs *after* binconfig's preprocess function
+icu_sysroot_preprocess () {
         sed -i -e s:^prefix=:prefix=\"${STAGING_DIR_TARGET}/usr\": ${STAGING_BINDIR_CROSS}/icu-config
 }