php: fixed build errors
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>
Wed, 21 Oct 2009 14:53:52 +0000 (16:53 +0200)
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>
Wed, 21 Oct 2009 14:53:52 +0000 (16:53 +0200)
recipes/php/php-5.2.6/string.c.patch [new file with mode: 0644]
recipes/php/php.inc
recipes/php/php_5.2.6.bb

diff --git a/recipes/php/php-5.2.6/string.c.patch b/recipes/php/php-5.2.6/string.c.patch
new file mode 100644 (file)
index 0000000..a24b887
--- /dev/null
@@ -0,0 +1,21 @@
+Index: php-5.2.6/ext/standard/string.c
+===================================================================
+--- php-5.2.6.orig/ext/standard/string.c
++++ php-5.2.6/ext/standard/string.c
+@@ -592,14 +592,12 @@ PHP_FUNCTION(nl_langinfo)
+ #endif
+ #ifdef DECIMAL_POINT
+               case DECIMAL_POINT:
+-#endif
+-#ifdef RADIXCHAR
++#elif RADIXCHAR
+               case RADIXCHAR:
+ #endif
+ #ifdef THOUSANDS_SEP
+               case THOUSANDS_SEP:
+-#endif
+-#ifdef THOUSEP
++#elif THOUSEP
+               case THOUSEP:
+ #endif
+ #ifdef GROUPING
index e9d49a3..0f9a420 100644 (file)
@@ -10,7 +10,7 @@ S = "${WORKDIR}/php-${PV}"
 
 inherit autotools
 
-CFLAGS += " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
+CFLAGS += " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED -D_GNU_SOURCE"
 
 acpaths = ""
 
index c6cb00f..38e8656 100644 (file)
@@ -2,9 +2,10 @@ require php.inc
 
 DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native"
 
-PR = "r5"
+PR = "r6"
 
-SRC_URI += "file://pear-makefile.patch;patch=1 "
+SRC_URI += "file://pear-makefile.patch;patch=1 \
+       file://string.c.patch;patch=1 "
 
 export THREADS="pthread"
 export LIBS=" -lpthread "