xchat: fix build for gtk 2.24
authorGrazvydas Ignotas <notasas@gmail.com>
Tue, 7 Oct 2014 23:45:46 +0000 (02:45 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Tue, 7 Oct 2014 23:45:46 +0000 (02:45 +0300)
recipes/xchat/xchat-2.8.6/xchat-2.8.6-gtk2.24.patch [new file with mode: 0644]
recipes/xchat/xchat_2.8.6.bb

diff --git a/recipes/xchat/xchat-2.8.6/xchat-2.8.6-gtk2.24.patch b/recipes/xchat/xchat-2.8.6/xchat-2.8.6-gtk2.24.patch
new file mode 100644 (file)
index 0000000..669bfbf
--- /dev/null
@@ -0,0 +1,40 @@
+diff -urp xchat-2.8.6_/config.log xchat-2.8.6/config.lodiff -urp xchat-2.8.6_/src/common/xchat.h xchat-2.8.6/src/common/xchat.h
+--- xchat-2.8.6_/src/common/xchat.h    2014-10-08 02:31:20.914795888 +0300
++++ xchat-2.8.6/src/common/xchat.h     2014-10-08 02:31:52.888494189 +0300
+@@ -1,10 +1,6 @@
+ #include "../../config.h"
+-#include <glib/gslist.h>
+-#include <glib/glist.h>
+-#include <glib/gutils.h>
+-#include <glib/giochannel.h>
+-#include <glib/gstrfuncs.h>
++#include <glib.h>
+ #include <time.h>                     /* need time_t */
+ #ifndef XCHAT_H
+Only in xchat-2.8.6/src/common: xchat.o
+diff -urp xchat-2.8.6_/src/fe-gtk/about.c xchat-2.8.6/src/fe-gtk/about.c
+--- xchat-2.8.6_/src/fe-gtk/about.c    2014-10-08 02:31:20.922795332 +0300
++++ xchat-2.8.6/src/fe-gtk/about.c     2014-10-08 02:35:25.309202332 +0300
+@@ -16,7 +16,7 @@
+  * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+  */
+-#define GTK_DISABLE_DEPRECATED
++// #define GTK_DISABLE_DEPRECATED
+ #include <stdio.h>
+ #include <stdlib.h>
+diff -urp xchat-2.8.6_/src/fe-gtk/maingui.c xchat-2.8.6/src/fe-gtk/maingui.c
+--- xchat-2.8.6_/src/fe-gtk/maingui.c  2014-10-08 02:31:20.922795332 +0300
++++ xchat-2.8.6/src/fe-gtk/maingui.c   2014-10-08 02:36:29.292596250 +0300
+@@ -16,7 +16,7 @@
+  * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+  */
+-#define GTK_DISABLE_DEPRECATED
++//#define GTK_DISABLE_DEPRECATED
+ #include <stdlib.h>
+ #include <string.h>
index 7591980..abd2fda 100644 (file)
@@ -4,10 +4,11 @@ HOMEPAGE = "http://www.xchat.org"
 SECTION = "x11/network"
 DEPENDS = "libgcrypt zlib gtk+"
 DEPENDS += "gdk-pixbuf-native"
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "http://www.xchat.org/files/source/2.8/xchat-${PV}.tar.bz2 \
-           file://xchat-2.8.6-gtk2.20.patch;patch=1 "
+           file://xchat-2.8.6-gtk2.20.patch;patch=1 \
+           file://xchat-2.8.6-gtk2.24.patch;patch=1 "
 
 inherit autotools