alsa-state: Set default config file for Pandora
authorMichael Mrozek <EvilDragon@openpandora.de>
Mon, 10 Oct 2011 22:48:10 +0000 (00:48 +0200)
committerMichael Mrozek <EvilDragon@openpandora.de>
Mon, 10 Oct 2011 22:48:10 +0000 (00:48 +0200)
recipes/alsa/alsa-state.bb
recipes/alsa/alsa-state/angstrom/asound.conf

index 9c3a282..d1acf81 100644 (file)
@@ -7,7 +7,7 @@
 DESCRIPTION = "Alsa Scenario Files"
 LICENSE = "MIT"
 PV = "0.2.0"
-PR = "r15"
+PR = "r16"
 
 SRC_URI = "\
   file://asound.conf \
index f7e0e4a..5d95b99 100644 (file)
@@ -1,2 +1,47 @@
-# default angstrom configuration
+pcm.dmixed {
+    type dmix
+    ipc_key 1234
+    slave {
+         pcm "hw:0"
+         buffer_size 8192
+         period_size 2048
+         #periods 128
+         period_time 0
+         buffer_time 0
+         rate 44100
+    }
+}
 
+
+pcm.softvol {
+    type softvol
+    slave {
+          pcm      "dmixed"
+    }
+    control {
+          name     "Master"
+          card 0
+    }
+}
+
+pcm.!default {
+    type     plug
+    slave.pcm   "softvol"
+}
+
+pcm.dsp0 {
+    type plug
+    slave {
+          pcm "hw:0"
+    }
+}
+
+ctl.dsp0 {
+    type plug
+    slave.pcm "hw:0"
+}
+
+ctl.mixer0 {
+    type plug
+    slave.pcm "hw:0"
+}