libxlavier: add 5.0, convert to new style staging
authorKoen Kooi <koen@openembedded.org>
Thu, 1 Apr 2010 11:37:01 +0000 (13:37 +0200)
committerKoen Kooi <koen@openembedded.org>
Thu, 1 Apr 2010 12:04:13 +0000 (14:04 +0200)
recipes/gnome/libxklavier_4.0.bb
recipes/gnome/libxklavier_5.0.bb [new file with mode: 0644]

index fb74980..6f39854 100644 (file)
@@ -20,7 +20,4 @@ do_compile_append() {
                   libxklavier.pc
 }
 
-do_stage() {
-       autotools_stage_all
-}
 
diff --git a/recipes/gnome/libxklavier_5.0.bb b/recipes/gnome/libxklavier_5.0.bb
new file mode 100644 (file)
index 0000000..9c70d6f
--- /dev/null
@@ -0,0 +1,24 @@
+DESCRIPTION = "Helper lib for keyboard management"
+LICENSE = "LGPL"
+
+DEPENDS = "xkbcomp gtk+ iso-codes "
+
+inherit gnome
+
+SRC_URI[archive.md5sum] = "134c7ea177ff901123b909de77394780"
+SRC_URI[archive.sha256sum] = "dfd94b17a752b2839281764f0a16af2b338024c8867c10fba7015f276dec4db0"
+
+EXTRA_OECONF = "--with-xkb-bin-base=/usr/bin"
+
+do_configure_append() {
+        find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+        find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
+}
+
+do_compile_append() {
+        sed -i -e s:${STAGING_DIR_TARGET}::g \
+               -e s:/${TARGET_SYS}::g \
+                  libxklavier.pc
+}
+
+