advancedcaching: new recipe from SHR
authorMartin Jansa <Martin.Jansa@gmail.com>
Wed, 18 Nov 2009 08:05:19 +0000 (09:05 +0100)
committerMartin Jansa <Martin.Jansa@gmail.com>
Wed, 18 Nov 2009 08:57:15 +0000 (09:57 +0100)
recipes/openmoko-3rdparty/advancedcaching_git.bb [new file with mode: 0644]

diff --git a/recipes/openmoko-3rdparty/advancedcaching_git.bb b/recipes/openmoko-3rdparty/advancedcaching_git.bb
new file mode 100644 (file)
index 0000000..2c2e14c
--- /dev/null
@@ -0,0 +1,22 @@
+DESCRIPTION = "Advanced Geocaching Tool for Linux - Towards paperless geocaching!"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.opkg.org/package_268.html"
+RDEPENDS = "python-pygtk python-html python-image python-netclient python-misc python-sqlite3 python-mime python-json"
+PV = "0.1.2+gitr${SRCPV}"
+
+SRC_URI = "git://github.com/webhamster/advancedcaching.git;protocol=git;branch=master"
+
+inherit setuptools
+
+S = "${WORKDIR}/git/files"
+
+do_install_append() {
+        mkdir -p "${D}/${datadir}/pixmaps"
+        install -m 0644 "${S}/advancedcaching.png" "${D}/${datadir}/pixmaps"
+        mkdir -p "${D}/${datadir}/applications"
+        install -m 0644 "${S}/advancedcaching.desktop" "${D}/${datadir}/applications"
+}
+
+FILES_${PN} += "/usr/share/applications/* /usr/share/pixmaps/*"