fso-abyss: version 0.3.0 supports a config file
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>
Sun, 15 Feb 2009 22:38:21 +0000 (23:38 +0100)
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>
Sun, 15 Feb 2009 22:38:21 +0000 (23:38 +0100)
packages/freesmartphone/fso-abyss/abyss.conf [new file with mode: 0644]
packages/freesmartphone/fso-abyss/om-gta01/abyss.conf [new file with mode: 0644]
packages/freesmartphone/fso-abyss/om-gta02/abyss.conf [new file with mode: 0644]
packages/freesmartphone/fso-abyss/om-gta03/abyss.conf [new file with mode: 0644]
packages/freesmartphone/fso-abyss_git.bb

diff --git a/packages/freesmartphone/fso-abyss/abyss.conf b/packages/freesmartphone/fso-abyss/abyss.conf
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/freesmartphone/fso-abyss/om-gta01/abyss.conf b/packages/freesmartphone/fso-abyss/om-gta01/abyss.conf
new file mode 100644 (file)
index 0000000..2ff579d
--- /dev/null
@@ -0,0 +1,16 @@
+[omuxerd]
+# set to 1, when the first AllocChannel request opens a session
+autoopen = 1
+# set to 1, when the last ReleaseChannel closes the session
+autoclose = 1
+# set to 1, when closing the session should close the program
+autoexit = 1
+
+[session]
+# set 0 for 07.10 basic multiplexing, 1 for advanced
+mode = 1
+# set maximum 07.10 frame size
+framesize = 98
+# configure modem port
+port = /dev/ttySAC0
+speed = 115200
diff --git a/packages/freesmartphone/fso-abyss/om-gta02/abyss.conf b/packages/freesmartphone/fso-abyss/om-gta02/abyss.conf
new file mode 100644 (file)
index 0000000..2ff579d
--- /dev/null
@@ -0,0 +1,16 @@
+[omuxerd]
+# set to 1, when the first AllocChannel request opens a session
+autoopen = 1
+# set to 1, when the last ReleaseChannel closes the session
+autoclose = 1
+# set to 1, when closing the session should close the program
+autoexit = 1
+
+[session]
+# set 0 for 07.10 basic multiplexing, 1 for advanced
+mode = 1
+# set maximum 07.10 frame size
+framesize = 98
+# configure modem port
+port = /dev/ttySAC0
+speed = 115200
diff --git a/packages/freesmartphone/fso-abyss/om-gta03/abyss.conf b/packages/freesmartphone/fso-abyss/om-gta03/abyss.conf
new file mode 100644 (file)
index 0000000..1764c5b
--- /dev/null
@@ -0,0 +1,16 @@
+[omuxerd]
+# set to 1, when the first AllocChannel request opens a session
+autoopen = 1
+# set to 1, when the last ReleaseChannel closes the session
+autoclose = 1
+# set to 1, when closing the session should close the program
+autoexit = 1
+
+[session]
+# set 0 for 07.10 basic multiplexing, 1 for advanced
+mode = 0
+# set maximum 07.10 frame size
+framesize = 98
+# configure modem port
+port = /dev/ttySAC0
+speed = 115200
index 45d2257..3cfff7d 100644 (file)
@@ -4,14 +4,33 @@ AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
 SECTION = "console/network"
 DEPENDS = "vala-native dbus dbus-glib libgsm0710"
 LICENSE = "GPL"
-PV = "0.2.1+gitr${SRCREV}"
+PV = "0.3.0+gitr${SRCREV}"
 PR = "r0"
 
-SRC_URI = "${FREESMARTPHONE_GIT}/fso-abyss.git;protocol=git;branch=master"
+SRC_URI = "\
+  ${FREESMARTPHONE_GIT}/fso-abyss.git;protocol=git;branch=master \
+  file://abyss.conf \
+"
 S = "${WORKDIR}/git"
 
 inherit autotools
 
-#RCONFLICTS = "gsm0710muxd fso-gsm0710muxd"
+do_install_append() {
+       install -d ${D}${sysconfdir}
+       install -m 0644 ${WORKDIR}/abyss.conf ${D}${sysconfdir}/
+}
 
-FILES_${PN} += "${datadir} ${sysconfdir}"
+PACKAGES =+ "${PN}-config"
+
+FILES_${PN} += "${sysconfdir} ${datadir}"
+RRECOMMENDS_${PN} = "${PN}-config"
+
+FILES_${PN}-config = "\
+  ${sysconfdir}/abyss.conf \
+"
+
+CONFFILES_${PN}-config = "\
+  ${sysconfdir}/abyss.conf \
+"
+
+PACKAGE_ARCH_${PN} = "${BASE_PACKAGE_ARCH}"