beecrypt: get patch from Poky to fix building on 64bit machines
authorRichard Purdie <richard@openedhand.com>
Mon, 18 Aug 2008 08:02:37 +0000 (08:02 +0000)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Thu, 19 Mar 2009 19:22:34 +0000 (20:22 +0100)
git-svn-id: https://svn.o-hand.com/repos/poky@5068 311d38ba-8fff-0310-9ca6-ca027cbcb966

recipes/beecrypt/beecrypt_3.1.0.bb
recipes/beecrypt/files/x64fix.patch [new file with mode: 0644]

index f9a45e7..720d99a 100644 (file)
@@ -4,9 +4,10 @@
 
 DESCRIPTION="Beecrypt is a general-purpose cryptography library."
 HOMEPAGE="http://sourceforge.net/projects/beecrypt"
-SRC_URI="${SOURCEFORGE_MIRROR}/beecrypt/beecrypt-${PV}.tar.gz"
+SRC_URI="${SOURCEFORGE_MIRROR}/beecrypt/beecrypt-${PV}.tar.gz \
+         file://x64fix.patch;patch=1"
 
-PR = "r2"
+PR = "r3"
 
 inherit autotools
 acpaths=""
@@ -14,15 +15,6 @@ acpaths=""
 EXTRA_OECONF="--with-arch=${TARGET_ARCH} --enable-shared --enable-static"
 
 do_stage() {
-
-#      oe_libinstall  -a  -C .libs libbeecrypt  ${STAGING_LIBDIR}
-       cp .libs/libbeecrypt.a ${STAGING_LIBDIR}/
-       install -d ${STAGING_INCDIR}/
-       install -d ${STAGING_INCDIR}/beecrypt
-       for X in beecrypt.h beecrypt.api.h memchunk.h mpnumber.h beecrypt.gnu.h mp.h mpopt.h blockmode.h endianness.h
-       do
-               install -m 0644 ${X} ${STAGING_INCDIR}/beecrypt/${X}
-       done
-
+    autotools_stage_all
 }
 
diff --git a/recipes/beecrypt/files/x64fix.patch b/recipes/beecrypt/files/x64fix.patch
new file mode 100644 (file)
index 0000000..9ee75c1
--- /dev/null
@@ -0,0 +1,20 @@
+Index: beecrypt-3.1.0/configure.ac
+===================================================================
+--- beecrypt-3.1.0.orig/configure.ac   2008-08-16 12:08:02.000000000 +0100
++++ beecrypt-3.1.0/configure.ac        2008-08-16 12:08:26.000000000 +0100
+@@ -754,15 +754,6 @@
+ # Check where to install the libraries
+ bc_libalt=
+-case $target_os in
+-linux*)
+-  case $bc_target_arch in
+-  alpha* | powerpc64 | s390x | x86_64)
+-    bc_libalt="64"
+-    ;;
+-  esac
+-  ;;
+-esac
+ AC_SUBST(LIBALT,$bc_libalt)
+ # Generate output files.