merge of '4d43ab58fc4f4986ece87cba9814bd2c1a63434d'
authorRod Whitby <rod@whitby.id.au>
Sun, 6 Apr 2008 10:21:21 +0000 (10:21 +0000)
committerRod Whitby <rod@whitby.id.au>
Sun, 6 Apr 2008 10:21:21 +0000 (10:21 +0000)
     and 'bcc47d35b4f4f02379b2ed9b7110078ab656814a'

16 files changed:
classes/testlab.bbclass
conf/distro/include/angstrom-glibc.inc
conf/distro/include/moko-autorev.inc
conf/machine/beagleboard.conf
conf/machine/include/tune-cortexa8.inc
conf/machine/include/tune-strongarm.inc
packages/glibc/files/glibc-includes-fixed-isystem.patch [new file with mode: 0644]
packages/klibc/files/dash_readopt.patch [new file with mode: 0644]
packages/klibc/klibc-common.inc
packages/klibc/klibc-utils-static_1.5.bb
packages/klibc/klibc_1.5.bb
packages/linux/linux-rp_2.6.24.bb
packages/ncurses/ncurses.inc
packages/ncurses/ncurses_5.4.bb
site/common
site/common-uclibc

index ba0bc79..bb47ee8 100644 (file)
@@ -32,7 +32,7 @@ if [ -e  ${IMAGE_ROOTFS}/etc/opkg ] ; then
        echo -e "digraph depends {\n    node [shape=plaintext]" > ${TESTLAB_DIR}/depends.dot
 
        for pkg in $(opkg-cl -f ${IMAGE_ROOTFS}/etc/opkg -o ${IMAGE_ROOTFS} list_installed | awk '{print $1}') ; do 
-               opkg-cl -f ${IMAGE_ROOTFS}/etc/opkg -o ${IMAGE_ROOTFS} info $pkg | grep Filename | awk -F: '{print $2}'  >> ${TESTLAB_DIR}/installed-packages.txt
+               opkg-cl -f ${IMAGE_ROOTFS}/etc/opkg -o ${IMAGE_ROOTFS} info $pkg | awk '/Package/ {printf $2"_"} /Version/ {printf $2"_"} /Archi/ {print $2".ipk"}'  >> ${TESTLAB_DIR}/installed-packages.txt
 
                for depends in $(opkg-cl -f ${IMAGE_ROOTFS}/etc/opkg -o  ${IMAGE_ROOTFS} info $pkg | grep Depends) ; do 
                        echo "$pkg OPP $depends;" | grep -v "(" | grep -v ")" | grep -v Depends | sed -e 's:,::g' -e 's:-:_:g' -e 's:\.:_:g' -e 's:+::g' |sed 's:OPP:->:g' >> ${TESTLAB_DIR}/depends.dot
@@ -57,7 +57,7 @@ if [ -e  ${IMAGE_ROOTFS}/etc/opkg ] ; then
        #dot -Tpng -o ${TESTLAB_DIR}/image-dependencies-nokernel-nolibc-noupdate-nomodules.png ${TESTLAB_DIR}/depends-nokernel-nolibc-noupdate-nomodules.dot
 
        for file in $(cat ${TESTLAB_DIR}/installed-packages.txt) ; do 
-               du -k $(find ${DEPLOY_DIR_IPK} -name "$file") 
+               du -k $(find ${DEPLOY_DIR_IPK} -name "$file") | head -n1
        done | grep "\.ipk" | sed -e s:${DEPLOY_DIR_IPK}::g | sort -n -r | awk '{print $1 "\tKiB " $2}' > ${TESTLAB_DIR}/installed-package-sizes.txt
 fi
 }
index f606395..f02e045 100644 (file)
@@ -12,10 +12,10 @@ TARGET_OS = "linux${@['','-gnueabi'][bb.data.getVar('TARGET_ARCH',d,1) in ['arm'
 # perl has some problems, see http://bugs.openembedded.org/show_bug.cgi?id=1616
 # [23:00] oxo: glibc (any version) on sparc does not like (repeat me) "-Os"
 
-FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os"
+FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -Os"
 FULL_OPTIMIZATION_pn-perl = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O1"
-FULL_OPTIMIZATION_pn-glibc-intermediate = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
-FULL_OPTIMIZATION_pn-glibc = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
+FULL_OPTIMIZATION_pn-glibc-intermediate = "-O2"
+FULL_OPTIMIZATION_pn-glibc = "-fexpensive-optimizations -fomit-frame-pointer -O2"
 FULL_OPTIMIZATION_sparc = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
 
 
index 96c37aa..1b466af 100644 (file)
@@ -1,3 +1,10 @@
+SRCREV_pn-assassin ?= "${AUTOREV}"
+SRCREV_pn-diversity-daemon ?= "${AUTOREV}"
+SRCREV_pn-diversity-nav ?= "${AUTOREV}"
+SRCREV_pn-dfu-util ?= "${AUTOREV}"
+SRCREV_pn-dfu-util-native ?= "${AUTOREV}"
+SRCREV_pn-illume ?= "${AUTOREV}"
+
 SRCREV_pn-libgsmd ?= "${AUTOREV}"
 SRCREV_pn-libjana ?= "${AUTOREV}"
 SRCREV_pn-libmokogsmd2 ?= "${AUTOREV}"
@@ -7,15 +14,9 @@ SRCREV_pn-libmokoui2 ?= "${AUTOREV}"
 SRCREV_pn-linux-openmoko ?= "${AUTOREV}"
 SRCREV_pn-linux-openmoko-devel ?= "${AUTOREV}"
 
-SRCREV_pn-assassin ?= "${AUTOREV}"
-SRCREV_pn-diversity-daemon ?= "${AUTOREV}"
-SRCREV_pn-diversity-nav ?= "${AUTOREV}"
+SRCREV_pn-multitap-pad ?= "${AUTOREV}"
 SRCREV_pn-moko-gtk-engine ?= "${AUTOREV}"
 SRCREV_pn-neod ?= "${AUTOREV}"
-SRCREV_pn-opkg ?= "${AUTOREV}"
-SRCREV_pn-opkg-native ?= "${AUTOREV}"
-
-SRCREV_pn-multitap-pad ?= "${AUTOREV}"
 
 SRCREV_pn-openmoko-appmanager2 ?= "${AUTOREV}"
 SRCREV_pn-openmoko-appearance ?= "${AUTOREV}"
@@ -52,12 +53,12 @@ SRCREV_pn-openmoko-worldclock2 ?= "${AUTOREV}"
 
 SRCREV_pn-openocd ?= "${AUTOREV}"
 SRCREV_pn-openocd-native ?= "${AUTOREV}"
+SRCREV_pn-opkg ?= "${AUTOREV}"
+SRCREV_pn-opkg-native ?= "${AUTOREV}"
 
 SRCREV_pn-python-gsmd ?= "${AUTOREV}"
 
 SRCREV_pn-u-boot-openmoko ?= "${AUTOREV}"
 SRCREV_pn-u-boot-openmoko-devel ?= "${AUTOREV}"
-SRCREV_pn-dfu-util ?= "${AUTOREV}"
-SRCREV_pn-dfu-util-native ?= "${AUTOREV}"
 SRCREV_pn-usbpath ?= "${AUTOREV}"
 SRCREV_pn-usbpath-native ?= "${AUTOREV}"
index ffbf155..ee074f6 100644 (file)
@@ -2,7 +2,7 @@
 #@NAME: Beagleboard machine
 #@DESCRIPTION: Machine configuration for the http://beagleboard.org/ board 
 TARGET_ARCH = "arm"
-PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te armv6 armv7 armv7-a"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te armv6 armv7 armv7a"
 
 PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive"
 XSERVER = "xserver-kdrive-fbdev"
index 2da31ec..03e2e86 100644 (file)
@@ -1,4 +1,3 @@
-# valid options for -march: `armv7', `armv7-a'
-TARGET_CC_ARCH = "-march=armv7 -mtune=cortex-a8 -mfpu=vfp -mfloat-abi=softfp"
-FEED_ARCH = "armv7"
-PACKAGE_ARCH = "armv7"
+TARGET_CC_ARCH = "-march=armv7-a -mtune=cortex-a8 -mfpu=vfp -mfloat-abi=softfp"
+FEED_ARCH = "armv7a"
+PACKAGE_ARCH = "armv7a"
index 448b28c..0a77314 100644 (file)
@@ -2,5 +2,6 @@
 # gcc does not differentiate between the different Strongarm versions, so neither do we
 # http://lists.linuxtogo.org/pipermail/openembedded-devel/2008-January/004031.html
 
+ARM_ABI = "oabi"
 TARGET_CC_ARCH = "-march=armv4 -mtune=strongarm"
 
diff --git a/packages/glibc/files/glibc-includes-fixed-isystem.patch b/packages/glibc/files/glibc-includes-fixed-isystem.patch
new file mode 100644 (file)
index 0000000..06668f4
--- /dev/null
@@ -0,0 +1,32 @@
+http://sourceware.org/ml/libc-alpha/2007-03/msg00017.html:
+
+GCC trunk now has multiple internal headers directories, one
+containing the self-contained GCC-provided headers and one containing
+the <limits.h> (not self-contained but including libc's <limits.h> or
+a fixed version thereof) and the fixed headers; more such directories
+may be added in future.
+
+When glibc uses -nostdinc, it needs to use -isystem options for all
+these internal directories.  This patch teaches it about the
+include-fixed directory (and is harmless with old GCC versions without
+that directory).
+
+2007-03-18  Joseph Myers  <joseph@codesourcery.com>
+
+       * configure.in: Also pass -isystem option for GCC's include-fixed
+       directory.
+       * configure: Regenerate.
+
+Index: configure.in
+===================================================================
+--- /tmp/configure.in  2008-04-05 19:20:52.176759390 +0200
++++ glibc-2.6.1/configure.in   2008-04-05 19:21:26.663424600 +0200
+@@ -912,7 +912,7 @@
+ # thing on a system that doesn't need fixincludes.  (Not presently a problem.)
+ if test -n "$sysheaders"; then
+   ccheaders=`$CC -print-file-name=include`
+-  SYSINCLUDES="-nostdinc -isystem $ccheaders \
++  SYSINCLUDES="-nostdinc -isystem $ccheaders -isystem $ccheaders-fixed \
+ -isystem `echo $sysheaders | sed 's/:/ -isystem /g'`"
+   if test -n "$CXX"; then
+     cxxversion=`$CXX -dumpversion 2>&AS_MESSAGE_LOG_FD` &&
diff --git a/packages/klibc/files/dash_readopt.patch b/packages/klibc/files/dash_readopt.patch
new file mode 100644 (file)
index 0000000..49bc087
--- /dev/null
@@ -0,0 +1,105 @@
+Index: klibc-1.5/usr/dash/miscbltin.c
+===================================================================
+--- klibc-1.5.orig/usr/dash/miscbltin.c        2008-03-27 20:38:09.354564817 +0100
++++ klibc-1.5/usr/dash/miscbltin.c     2008-04-04 18:05:32.063364195 +0200
+@@ -46,6 +46,7 @@
+ #include <ctype.h>
+ #include <stdint.h>
+ #include <time.h>             /* strtotimeval() */
++#include <termios.h>
+ #include "shell.h"
+ #include "options.h"
+@@ -83,6 +84,11 @@
+       int timeout;
+       int i;
+       fd_set set;
++      int n_flag = 0;
++      unsigned int nchars = 0;
++      int silent = 0;
++      struct termios tty, old_tty;
++
+       struct timeval ts, t0, t1, to;
+       ts.tv_sec = ts.tv_usec = 0;
+@@ -90,11 +96,18 @@
+       rflag = 0;
+       timeout = 0;
+       prompt = NULL;
+-      while ((i = nextopt("p:rt:")) != '\0') {
++      while ((i = nextopt("p:rt:n:s")) != '\0') {
+               switch(i) {
+               case 'p':
+                       prompt = optionarg;
+                       break;
++              case 'n':
++                      nchars = strtoul(optionarg, NULL, 10);
++                      n_flag = nchars; /* just a flag "nchars is nonzero" */
++                      break;
++              case 's':
++                      silent = 1;
++                      break;
+               case 't':
+                       p = strtotimeval(optionarg, &ts);
+                       if (*p || (!ts.tv_sec && !ts.tv_usec))
+@@ -118,6 +131,23 @@
+               sh_error("arg count");
+       if ((ifs = bltinlookup("IFS")) == NULL)
+               ifs = defifs;
++      if (n_flag || silent) {
++              if (tcgetattr(0, &tty) != 0) {
++                      /* Not a tty */
++                      n_flag = 0;
++                      silent = 0;
++              } else {
++                      old_tty = tty;
++                      if (n_flag) {
++                              tty.c_lflag &= ~ICANON;
++                              tty.c_cc[VMIN] = nchars < 256 ? nchars : 255;
++                      }
++                      if (silent) {
++                              tty.c_lflag &= ~(ECHO | ECHOK | ECHONL);
++                      }
++                      tcsetattr(0, TCSANOW, &tty);
++              }
++      }
+       status = 0;
+       startword = 1;
+       backslash = 0;
+@@ -133,13 +163,15 @@
+               ts.tv_sec += t0.tv_sec;
+       }
+       STARTSTACKSTR(p);
+-      for (;;) {
++      do {
+               if (timeout) {
+                       gettimeofday(&t1, NULL);
+                       if (t1.tv_sec > ts.tv_sec ||
+                           (t1.tv_sec == ts.tv_sec &&
+                            t1.tv_usec >= ts.tv_usec)) {
+                               status = 1;
++                              if (n_flag)
++                                      tcsetattr(0, TCSANOW, &old_tty);
+                               break;  /* Timeout! */
+                       }
+@@ -156,6 +188,8 @@
+                       FD_SET(0, &set);
+                       if (select(1, &set, NULL, NULL, &to) != 1) {
+                               status = 1;
++                              if (n_flag)
++                                      tcsetattr(0, TCSANOW, &old_tty);
+                               break; /* Timeout! */
+                       }
+               }
+@@ -191,7 +225,9 @@
+ put:
+                       STPUTC(c, p);
+               }
+-      }
++      } while (!n_flag || --nchars);
++      if (n_flag || silent)
++              tcsetattr(0, TCSANOW, &old_tty);
+       STACKSTRNUL(p);
+       /* Remove trailing blanks */
+       while ((char *)stackblock() <= --p && strchr(ifs, *p) != NULL)
index 41859d3..5e890b3 100644 (file)
@@ -8,6 +8,7 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/libs/klibc/Stable/klibc-${PV}.tar.bz2 \
           file://fstype-sane-vfat-and-jffs2-for-1.5.patch;patch=1 \
           file://modprobe.patch;patch=1 \
           file://losetup.patch;patch=1 \
+          file://dash_readopt.patch;patch=1 \
           "
 S = "${WORKDIR}/klibc-${PV}"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
index c6f5448..f0429e3 100644 (file)
@@ -1,6 +1,6 @@
 require klibc-common.inc
 
-PR = "r8"
+PR = "r9"
 
 # We only want the static utils. klibc build both. So we install only what we want.                            
 do_install() {
index 925dcd0..967f88f 100644 (file)
@@ -1,2 +1,2 @@
 require klibc.inc
-PR = "r6"
+PR = "r7"
index 84a479e..62dca60 100644 (file)
@@ -1,6 +1,6 @@
 require linux-rp.inc
 
-PR = "r8"
+PR = "r9"
 
 DEFAULT_PREFERENCE = "-1"
 DEFAULT_PREFERENCE_collie = "1"
@@ -100,7 +100,7 @@ SRC_URI_append_collie = "\
        ${TKSRC}/linux-2.6.24-SIMpad-rtc-sa1100.patch;patch=1 \
        ${TKSRC}/sa1100_spinlock.patch;patch=1 \
        ${TKSRC}/sa1100-dma.patch;patch=1 \
-       ${TKSRC}/sa1100_udc_g_ether.patch;patch=1 \
+       ${TKSRC}/sa1100_udc_g_ether-2.patch;patch=1 \
 "
 
 SRC_URI_append_poodle = "\
index 9b4fff5..7b1d2cb 100644 (file)
@@ -83,6 +83,9 @@ pkg_prerm_ncurses-tools () {
 
 PACKAGES =+ "${PN}-ncurses ${PN}-panel ${PN}-menu ${PN}-form ${PN}-terminfo ${PN}-tools"
 FILES_${PN}-ncurses = "${libdir}/libncurses.so.*"
+# You can'r really run any ncurses app without terminfo files, which is why the packaging was that way before mickeyl broke it. 
+# This RRECOMMENDS should pull in terminfo to fix that 
+RRECOMMENDS_${PN}-ncurses = "${PN}-terminfo"
 FILES_${PN}-panel = "${libdir}/libpanel.so.*"
 FILES_${PN}-menu = "${libdir}/libmenu.so.*"
 FILES_${PN}-form = "${libdir}/libform.so.*"
index 00dd7d1..d73164d 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r13"
+PR = "r14"
 
 SRC_URI = "${GNU_MIRROR}/ncurses/ncurses-${PV}.tar.gz \
            file://visibility.patch;patch=1"
index 9076688..dab8d7f 100644 (file)
@@ -3,3 +3,4 @@ mr_cv_target_elf=${mr_cv_target_elf=yes}
 
 # Normally kernels have /dev/random enabled
 ac_cv_file__dev_random=${ac_cv_file__dev_random=yes}
+
index 3112d3e..e93c345 100644 (file)
@@ -1,5 +1,12 @@
 # general
 ac_cv_have_decl_sys_siglist=${ac_cv_have_decl_sys_siglist=no}
+ac_cv_af_unix_large_dgram=${ac_cv_af_unix_large_dgram=yes}
+ac_cv_have_setresuid_decl=${ac_cv_have_setresuid_decl=yes}
+ac_cv_func_setresuid=${ac_cv_func_setresuid=yes}
+ac_cv_va_copy=${ac_cv_va_copy=yes}
+ac_cv___va_copy=${ac_cv___va_copy=yes}
+ac_cv_func_va_copy=${ac_cv_func_va_copy=yes}
+ac_cv_func___va_copy=${ac_cv_func___va_copy=yes}
 
 #dbus-glib
 ac_cv_have_abstract_sockets=${ac_cv_have_abstract_sockets=yes}