git: Upgrade recipes from 1.7.0.2 -> 1.7.3.5
authorKhem Raj <raj.khem@gmail.com>
Fri, 28 Jan 2011 04:25:55 +0000 (20:25 -0800)
committerGrazvydas Ignotas <notasas@gmail.com>
Sat, 19 Jul 2014 00:31:51 +0000 (03:31 +0300)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Conflicts:

recipes/git/git-native_1.7.3.5.bb
recipes/git/git_1.7.3.5.bb

recipes/git/files/git-less-hardlinks.diff
recipes/git/git-native_1.7.3.5.bb [moved from recipes/git/git-native_1.7.0.2.bb with 51% similarity]
recipes/git/git_1.7.3.5.bb [moved from recipes/git/git_1.7.0.2.bb with 94% similarity]

index 183fe8f..b104727 100644 (file)
@@ -15,9 +15,11 @@ This patch isn't complete though:
 
 ---
 
---- /tmp/Makefile      2010-05-15 09:39:26.000000000 +0200
-+++ git-1.7.0.2/Makefile       2010-05-15 09:44:21.000000000 +0200
-@@ -1453,7 +1453,6 @@
+Index: git-1.7.3.5/Makefile
+===================================================================
+--- git-1.7.3.5.orig/Makefile
++++ git-1.7.3.5/Makefile
+@@ -1619,7 +1619,6 @@ builtin/help.s builtin/help.o: EXTRA_CPP
  
  $(BUILT_INS): git$X
        $(QUIET_BUILT_IN)$(RM) $@ && \
@@ -25,7 +27,7 @@ This patch isn't complete though:
        ln -s git$X $@ 2>/dev/null || \
        cp git$X $@
  
-@@ -1626,7 +1625,6 @@
+@@ -1936,7 +1935,6 @@ git-http-push$X: revision.o http.o http-
  
  $(REMOTE_CURL_ALIASES): $(REMOTE_CURL_PRIMARY)
        $(QUIET_LNCP)$(RM) $@ && \
@@ -33,17 +35,25 @@ This patch isn't complete though:
        ln -s $< $@ 2>/dev/null || \
        cp $< $@
  
-@@ -1830,13 +1828,11 @@
-               cp "$$bindir/git$X" "$$execdir/git$X"; } ; } && \
-       { for p in $(BUILT_INS); do \
+@@ -2134,20 +2132,18 @@ endif
+       } && \
+       for p in $(filter $(install_bindir_programs),$(BUILT_INS)); do \
+               $(RM) "$$bindir/$$p" && \
+-              ln "$$bindir/git$X" "$$bindir/$$p" 2>/dev/null || \
+               ln -s "git$X" "$$bindir/$$p" 2>/dev/null || \
+               cp "$$bindir/git$X" "$$bindir/$$p" || exit; \
+       done && \
+       for p in $(BUILT_INS); do \
                $(RM) "$$execdir/$$p" && \
 -              ln "$$execdir/git$X" "$$execdir/$$p" 2>/dev/null || \
                ln -s "git$X" "$$execdir/$$p" 2>/dev/null || \
                cp "$$execdir/git$X" "$$execdir/$$p" || exit; \
-         done; } && \
-       { for p in $(REMOTE_CURL_ALIASES); do \
+       done && \
+       remote_curl_aliases="$(REMOTE_CURL_ALIASES)" && \
+       for p in $$remote_curl_aliases; do \
                $(RM) "$$execdir/$$p" && \
 -              ln "$$execdir/git-remote-http$X" "$$execdir/$$p" 2>/dev/null || \
++ || \
                ln -s "git-remote-http$X" "$$execdir/$$p" 2>/dev/null || \
                cp "$$execdir/git-remote-http$X" "$$execdir/$$p" || exit; \
-         done; } && \
+       done && \
similarity index 51%
rename from recipes/git/git-native_1.7.0.2.bb
rename to recipes/git/git-native_1.7.3.5.bb
index 7daee84..446ee8d 100644 (file)
@@ -1,9 +1,9 @@
 require git.inc
 inherit native
+SRC_URI[src.md5sum] = "8a8cd93b8a4dff0a03c0fdc77253af3e"
+SRC_URI[src.sha256sum] = "41682e4c13b43591b61a96b6f7a549b24863f62dfc4a917b6147c8e708e288a6"
 DEPENDS = "openssl-native curl-native zlib-native expat-native"
-PR = "r4"
-SRC_URI[src.md5sum] = "76518fa774b36de81d160b85fa4f19c1"
-SRC_URI[src.sha256sum] = "5601df7fc282fdd66de196b282694eb77dcfc50438f01587de144b3ead1a6b2f"
+PR = "r0"
 
 EXTRA_OECONF_append = " --without-python"
 EXTRA_OEMAKE = "NO_TCLTK=1"
similarity index 94%
rename from recipes/git/git_1.7.0.2.bb
rename to recipes/git/git_1.7.3.5.bb
index 526c888..5b76ca0 100644 (file)
@@ -1,8 +1,5 @@
 require git.inc
 
-SRC_URI[src.md5sum] = "76518fa774b36de81d160b85fa4f19c1"
-SRC_URI[src.sha256sum] = "5601df7fc282fdd66de196b282694eb77dcfc50438f01587de144b3ead1a6b2f"
-
 SRC_URI += "file://git-less-hardlinks.diff;patch=1"
 
 EXTRA_OECONF += "ac_cv_snprintf_returns_bogus=no ac_cv_c_c99_format=yes"
@@ -13,8 +10,9 @@ RDEPENDS_${PN} = "findutils sed"
 
 # Dropbear ssh needs a wrapper script, so install openssh-ssh to make it work out of the box
 RRECOMMENDS_${PN} = "openssh-ssh"
-
-PR = "r10"
+SRC_URI[src.md5sum] = "8a8cd93b8a4dff0a03c0fdc77253af3e"
+SRC_URI[src.sha256sum] = "41682e4c13b43591b61a96b6f7a549b24863f62dfc4a917b6147c8e708e288a6"
+PR = "r0"
 
 do_install_append() {
        # Fix broken hardlinks