fennec: update to latest tip
authorKoen Kooi <koen@openembedded.org>
Tue, 1 Sep 2009 20:42:07 +0000 (22:42 +0200)
committerKoen Kooi <koen@openembedded.org>
Tue, 1 Sep 2009 20:42:07 +0000 (22:42 +0200)
* fix up buildsystem contamination bug in firefox.inc while I'm at it as well

recipes/mozilla/fennec_hg.bb
recipes/mozilla/firefox.inc

index 9499613..ef4cedd 100644 (file)
@@ -1,12 +1,12 @@
 DESCRIPTION = "Mozilla Mobile browser"
 
-PV = "0.9+1.0b2pre"
-MOZPV = "1.0b2pre"
-PR = "r5"
+PV = "0.9+1.0b4pre"
+MOZPV = "1.0b4pre"
+PR = "r7"
 PE = "1"
 
-SRC_URI = "hg://hg.mozilla.org/;module=mozilla-central;rev=8c9a6d851018 \
-           hg://hg.mozilla.org/;module=mobile-browser;rev=c24b8b4ade53 \
+SRC_URI = "hg://hg.mozilla.org/;module=mozilla-central;rev=37acc871cb55 \
+           hg://hg.mozilla.org/;module=mobile-browser;rev=c725e5e30b9d \
            file://jsautocfg.h \
            file://jsautocfg-dontoverwrite.patch;patch=1 \
            file://use-native-bpp.patch;patch=1 \
@@ -20,7 +20,7 @@ require firefox.inc
 DEPENDS += "libnotify autoconf213-native cairo alsa-lib sqlite3"
 
 PARALLEL_MAKE = ""
-export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
+
 FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
 
 export LIBXUL_DIST="${S}/objdir/xulrunner/dist/"
index 1be9c4d..8526a8d 100644 (file)
@@ -30,6 +30,13 @@ FILES_${PN}-dbg += " ${libdir}/${PN}-*/.debug \
                        ${bindir}/.debug \
                        "
 
+export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
+
+# Due to sysroot we need to sed out references to the target staging when building the native version of xpidl
+# Symptons of the failure include "gthread.h:344: error: size of array 'type name' is negative"
+export HOST_LIBIDL_CFLAGS = "`${HOST_LIBIDL_CONFIG} --cflags | sed -e s:${STAGING_DIR_TARGET}:${STAGING_DIR_NATIVE}:g`"
+
+
 do_install() {
        oe_runmake DESTDIR="${D}" destdir="${D}" install
        install -d ${D}${datadir}/applications