linux-libc-headers_2.6.31.bb: Use __u8 instead of u8
authorKhem Raj <raj.khem@gmail.com>
Fri, 12 Mar 2010 06:52:55 +0000 (22:52 -0800)
committerKhem Raj <raj.khem@gmail.com>
Fri, 12 Mar 2010 06:55:48 +0000 (22:55 -0800)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
recipes/linux-libc-headers/linux-libc-headers-2.6.31/scsi-use-__u8.patch [new file with mode: 0644]
recipes/linux-libc-headers/linux-libc-headers_2.6.31.bb

diff --git a/recipes/linux-libc-headers/linux-libc-headers-2.6.31/scsi-use-__u8.patch b/recipes/linux-libc-headers/linux-libc-headers-2.6.31/scsi-use-__u8.patch
new file mode 100644 (file)
index 0000000..b754879
--- /dev/null
@@ -0,0 +1,26 @@
+This patch is from 
+http://patchwork.kernel.org/patch/38102/
+It seems its still under discussion and it will involve glibc to get it fixed correctly.
+for now OE uses scsi headers from kernel and not from glibc.
+
+-Khem
+
+Index: linux-2.6.31/include/scsi/scsi.h
+===================================================================
+--- linux-2.6.31.orig/include/scsi/scsi.h      2010-03-11 19:44:49.134590561 -0800
++++ linux-2.6.31/include/scsi/scsi.h   2010-03-11 19:45:12.744466326 -0800
+@@ -142,10 +142,10 @@ struct scsi_cmnd;
+ /* defined in T10 SCSI Primary Commands-2 (SPC2) */
+ struct scsi_varlen_cdb_hdr {
+-      u8 opcode;        /* opcode always == VARIABLE_LENGTH_CMD */
+-      u8 control;
+-      u8 misc[5];
+-      u8 additional_cdb_length;         /* total cdb length - 8 */
++      __u8 opcode;        /* opcode always == VARIABLE_LENGTH_CMD */
++      __u8 control;
++      __u8 misc[5];
++      __u8 additional_cdb_length;         /* total cdb length - 8 */
+       __be16 service_action;
+       /* service specific data follows */
+ };
index 08a871e..f01af4e 100644 (file)
@@ -2,12 +2,13 @@ require linux-libc-headers.inc
 
 INHIBIT_DEFAULT_DEPS = "1"
 DEPENDS += "unifdef-native"
-PR = "r2"
+PR = "r3"
 
 DEFAULT_PREFERENCE = "-1"
 
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
            file://0001-implement-TIF_RESTORE_SIGMASK-support-and-enable-the.patch;patch=1 \
+           file://scsi-use-__u8.patch;patch=1 \
          "
 S = "${WORKDIR}/linux-${PV}"