realpath: added 1.10
authorMartyn Welch <martyn.welch@ge.com>
Sun, 21 Mar 2010 23:34:46 +0000 (23:34 +0000)
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Tue, 30 Mar 2010 12:19:59 +0000 (14:19 +0200)
The package contains a small utility realpath, which converts each
pathname argument to an absolute pathname, which has no components
that are symbolic links or the special .  or ..  directory entries.

This utility provides mostly the same functionality as `/bin/readlink -f'
in the coreutils package.

Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
recipes/realpath/files/makefile.patch [new file with mode: 0644]
recipes/realpath/realpath_1.10.bb [new file with mode: 0644]

diff --git a/recipes/realpath/files/makefile.patch b/recipes/realpath/files/makefile.patch
new file mode 100644 (file)
index 0000000..d97ba59
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN realpath-1.10.orig/Makefile realpath-1.10/Makefile
+--- realpath-1.10.orig/Makefile        2009-07-28 16:04:11.000000000 +0100
++++ realpath-1.10/Makefile     2009-07-28 16:08:44.000000000 +0100
+@@ -3,7 +3,7 @@
+ # "@(#)realpath:$Id: Makefile,v 1.30 2006-05-07 19:41:41 robert Exp $"
+ #
+-VERSION       = $(shell dpkg-parsechangelog | sed -ne 's/^Version: *//p')
++#VERSION      = $(shell dpkg-parsechangelog | sed -ne 's/^Version: *//p')
+ CC    = gcc
+ CFLAGS        = -Wall -Wstrict-prototypes -Wmissing-prototypes -DVERSION='"$(VERSION)"' 
diff --git a/recipes/realpath/realpath_1.10.bb b/recipes/realpath/realpath_1.10.bb
new file mode 100644 (file)
index 0000000..4833740
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "Return the canonicalized absolute pathname"
+SECTION = "utility"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/r/realpath/realpath_${PV}.tar.gz;name=realpath \
+           file://makefile.patch;patch=1"
+
+SRC_URI[realpath.md5sum] = "1f2b2bceaacadf79162a9cbb5956c3b6"
+SRC_URI[realpath.sha256sum] = "72199f9c11d1f9a36b3b9693988b558a167def6b88fa146ea6a7f7223f96c535"
+
+CFLAGS += "-DVERSION=${PV}"
+
+do_install () {
+       install -d ${D}${bindir}
+       install -p -m 0755 ${S}/realpath ${D}${bindir}
+}