elementary-icon-theme: Add recipes and checksums for the Elementary icon theme.
authorDavid-John Willis <John.Willis@Distant-earth.com>
Wed, 25 Nov 2009 10:42:19 +0000 (10:42 +0000)
committerDavid-John Willis <John.Willis@Distant-earth.com>
Thu, 8 Apr 2010 07:19:34 +0000 (08:19 +0100)
* The icon theme is from http://www.elementary-project.com/.

conf/checksums.ini
recipes/elementary-icon-theme/elementary-icon-theme-enable.bb [new file with mode: 0644]
recipes/elementary-icon-theme/elementary-icon-theme_2.2.bb [new file with mode: 0644]

index c8937d3..58ff90b 100644 (file)
@@ -6118,6 +6118,10 @@ sha256=21032e8a420365d0539c6356d220bb8634e9c1ee839bfcceb3c03d9e427cd397
 md5=a545490e03a6b49f00253bf0d692f362
 sha256=6a624b741b110b5b1d9cdff8179760f52b0a623bf597b8e6be757fc18af20a4c
 
+[http://launchpad.net/elementaryicons/trunk/2.2/+download/elementary_2.2.tar.gz]
+md5=fb740a046d8d728613499a77b77bc1e2
+sha256=49672fc965b30cc6c5c2589a1b72c5187a2d185e7f6d599968172fd694f28ea6
+
 [http://effbot.org/media/downloads/elementtree-1.2.7-20070827-preview.zip]
 md5=30e2fe5edd143f347e03a8baf5d60f8a
 sha256=5071431068c58c1f56dcc8fff37f8a213351f3b45c012d3adb640ec9418053ad
diff --git a/recipes/elementary-icon-theme/elementary-icon-theme-enable.bb b/recipes/elementary-icon-theme/elementary-icon-theme-enable.bb
new file mode 100644 (file)
index 0000000..fc34583
--- /dev/null
@@ -0,0 +1,14 @@
+DESCRIPTION = "Enable elementary-icon-theme in gtkrc"
+
+RDEPENDS = "elementary-icon-theme"
+
+ALLOW_EMPTY_${PN} = "1"
+PACKAGE_ARCH = "all"
+
+pkg_postinst() {
+#!/bin/sh
+mkdir -p $D${sysconfdir}/gtk-2.0
+touch $D${sysconfdir}/gtk-2.0/gtkrc
+sed -i /gtk-icon-theme-name/d $D${sysconfdir}/gtk-2.0/gtkrc
+echo 'gtk-icon-theme-name = "elementary"' >> $D${sysconfdir}/gtk-2.0/gtkrc
+}
diff --git a/recipes/elementary-icon-theme/elementary-icon-theme_2.2.bb b/recipes/elementary-icon-theme/elementary-icon-theme_2.2.bb
new file mode 100644 (file)
index 0000000..81f1657
--- /dev/null
@@ -0,0 +1,33 @@
+SECTION = "x11/icons"
+DESCRIPTION = "Icon theme from the Elementary project"
+HOMEPAGE = "http://www.elementary-project.com/"
+
+RDEPENDS = "gnome-icon-theme hicolor-icon-theme"
+
+PR = "r0"
+
+# We have to get the icons from a mirror (LaunchPad) as DeviantArt has a download 
+# wrapper to stop simple HTTP gets :(.
+
+SRC_URI = " \
+  http://launchpad.net/elementaryicons/trunk/2.2/+download/elementary_2.2.tar.gz \
+"
+
+S = "${WORKDIR}/elementary_2.2"
+
+do_install() {
+        install -d ${D}${datadir}/icons/
+        install -d ${D}${datadir}/icons/elementary/
+        cp -r ${S}/* "${D}${datadir}/icons/elementary/"
+}
+
+FILES_${PN} = "${datadir}/icons/elementary/"
+
+PACKAGE_ARCH = "all"
+
+pkg_postinst_${PN} () {
+  if [ "x$D" != "x" ]; then
+    exit 1
+  fi
+  gtk-update-icon-cache -q /usr/share/icons/elementary
+}