samba: Make 3.0.23c build again since its still an om preferred version
authorTim 'timtim' Ellis <tim.ellis@foonas.org>
Mon, 26 Jan 2009 00:07:10 +0000 (00:07 +0000)
committerTim 'timtim' Ellis <tim.ellis@foonas.org>
Mon, 26 Jan 2009 00:07:10 +0000 (00:07 +0000)
packages/samba/samba_3.0.23c.bb

index 96343aa..369833a 100644 (file)
@@ -31,6 +31,12 @@ EXTRA_OECONF += "\
        --with-swatdir=${datadir}/swat \
        "
 
+do_compile () {
+        oe_runmake proto_exists
+        base_do_compile
+        ${CC} client/mount.cifs.c -o mount.cifs
+}
+
 do_install_append() {
        install -d "${D}${localstatedir}/log"
        install -d "${D}${sysconfdir}/init.d"
@@ -39,6 +45,11 @@ do_install_append() {
        install -c -m 644 ../examples/smb.conf.default ${D}${sysconfdir}/samba/smb.conf
 }
 
+do_stage() {
+       install -m 0644 include/libsmbclient.h ${STAGING_INCDIR}
+       oe_libinstall -C bin -a -so libsmbclient ${STAGING_LIBDIR}
+}
+
 PACKAGES =+ "swat"
 
 FILES_swat = "${sbindir}/swat ${datadir}/swat ${libdir}/*.msg"