mcnavi: replace link to (sometimes) non-existent INSTALL file with empty file
authorMartin Jansa <Martin.Jansa@gmail.com>
Fri, 2 Apr 2010 05:20:34 +0000 (07:20 +0200)
committerMartin Jansa <Martin.Jansa@gmail.com>
Fri, 2 Apr 2010 05:20:34 +0000 (07:20 +0200)
recipes/openmoko-3rdparty/mcnavi_0.2.5.bb

index 7c87a58..973023e 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Free GPS navigation for car and outdoor with OpenStreetMap maps"
 HOMEPAGE = "http://www.gps-routes.info/index.php?name=Content&pa=showpage&pid=1"
 LICENSE = "GPL"
 DEPENDS = "ecore evas imlib2 gpsd edje-native"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://www.gps-routes.info/debian/pool/main/m/mcnavi/mcnavi_${PV}.tar.gz;name=archive \
            file://gpsd-2.90.patch;patch=1"
@@ -12,4 +12,9 @@ SRC_URI[archive.sha256sum] = "ee6792bef93070319141ee2020b7ae376527e3b8043f0f540b
 
 S = "${WORKDIR}/${PN}"
 
+do_configure_prepend() {
+  # replace link to (sometimes) non-existent file with empty file
+  rm -f ${S}/INSTALL; touch ${S}/INSTALL
+}
+
 inherit autotools