many recipes: Recipes must not depend on gconf-dbus directly, only dbus can be referred:
authorStanislav Brabec <utx@penguin.cz>
Wed, 21 Oct 2009 20:40:28 +0000 (20:40 +0000)
committerutx@penguin.cz <utx@penguin.cz>
Wed, 21 Oct 2009 20:40:28 +0000 (20:40 +0000)
* Only PREFERRED_PROVIDER_gconf in distro definition can refer to gconf-dbus.
* Both gconf-dbus and gconf provide than same interface.
* New gconf packages already provide defaults settings via dbus.
* Increment PR to rebuild against correct package.

17 files changed:
recipes/geoclue/geoclue_git.bb
recipes/gkdial/gkdial_1.8.1.bb
recipes/gpephone/firewall_svn.bb
recipes/gpephone/libsettings_0.3.bb
recipes/gpephone/libsettings_svn.bb
recipes/maemo4/libhildon.inc
recipes/moblin/mojito_git.bb
recipes/networkmanager/networkmanager.inc
recipes/networkmanager/networkmanager_0.6.4.bb
recipes/packagekit/gnome-packagekit_2.27.1.bb
recipes/tasks/task-gmae.bb
recipes/tasks/task-sdk-extra.bb
recipes/tinymail/libtinymail.inc
recipes/tinymail/libtinymail_0.0.1.bb
recipes/tinymail/libtinymail_svn.bb
recipes/tinymail/tmut_1.1.0.bb
recipes/tinymail/tmut_svn.bb

index 2cdaa25..b7950a9 100644 (file)
@@ -5,6 +5,7 @@ DEPENDS = "libgpsmgr libgpsbt gtk+ gypsy libxml2 gconf libsoup dbus-glib"
 
 SRCREV = "3a31d260074397a968afaf1065856ab763befb01"
 PV = "0.11.1"
+PR = "r1"
 PR_append = "+gitr${SRCREV}"
 PE = "1"
 
index 3208a06..53caca3 100644 (file)
@@ -1,12 +1,12 @@
 inherit autotools pkgconfig gconf
 
 DESCRIPTION = "GTK PPP dialing tool"
-DEPENDS = "gconf-dbus gtk+ libglade gettext ppp gpe-su"
-RDEPENDS = "ppp gconf-dbus gpe-su"
+DEPENDS = "gconf gtk+ libglade gettext ppp gpe-su"
+RDEPENDS = "ppp gconf gpe-su"
 SECTION = "gpe"
 PRIORITY = "optional"
 
-PR = "r3gpe1"
+PR = "r4"
 
 SRC_URI = "http://familiar.handhelds.org/source/v0.8.2/${PN}-${PV}.tar.gz \
            file://gkdial-pgpe.patch;patch=1 \
index b3d7aee..6c3ed64 100644 (file)
@@ -2,12 +2,12 @@ LICENSE     = "LiPS"
 DESCRIPTION = "Cellphone firewall tool"
 SECTION = "gpe"
 PRIORITY    = "optional"
-PR          = "r0"
+PR          = "r1"
 PV = "0.0+svnr-${SRCREV}"
 
 DEFAULT_PREFERENCE = "-1"
 
-DEPENDS = "gtk+ libmsgenabler libabenabler libiac libgpewidget libgpephone gconf-dbus"
+DEPENDS = "gtk+ libmsgenabler libabenabler libiac libgpewidget libgpephone gconf"
 
 inherit gpephone autotools pkgconfig
 
index 22f8c4f..3c9794e 100644 (file)
@@ -2,7 +2,8 @@ DESCRIPTION = "G(PE)^2 settings API library"
 SECTION = "gpe/libs"
 PRIORITY = "required"
 LICENSE = "LiPS"
-DEPENDS = "glib-2.0 gconf-dbus"
+DEPENDS = "glib-2.0 gconf"
+PR = "r1"
 
 inherit gpephone pkgconfig autotools
 
index 74e1190..770fe8c 100644 (file)
@@ -2,8 +2,9 @@ DESCRIPTION = "G(PE)^2 settings API library"
 SECTION = "gpe/libs"
 PRIORITY = "required"
 LICENSE = "LiPS"
-DEPENDS = "glib-2.0 gconf-dbus"
+DEPENDS = "glib-2.0 gconf"
 PV = "0.0+svnr-${SRCREV}"
+PR = "r1"
 
 DEFAULT_PREFERENCE = "-1"
 
index bab16cf..534603d 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Hildon widget library"
 LICENSE = "LGPL"
 
-DEPENDS = "gconf-dbus esound gtk+"
+DEPENDS = "gconf esound gtk+"
 
 inherit autotools pkgconfig lib_package
 
index b29aaed..f9104a9 100644 (file)
@@ -1,9 +1,9 @@
 
 SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git"
 PV = "0.0+git${SRCREV}"
-PR = "r2"
+PR = "r3"
 
-DEPENDS = "libsoup-2.4 gconf-dbus librest glib-2.0 twitter-glib sqlite3 gnome-keyring"
+DEPENDS = "libsoup-2.4 gconf librest glib-2.0 twitter-glib sqlite3 gnome-keyring"
 
 S = "${WORKDIR}/git"
 
index ead854c..c159883 100644 (file)
@@ -3,7 +3,7 @@ SECTION = "net/misc"
 LICENSE = "GPL"
 HOMEPAGE = "http://www.gnome.org"
 PRIORITY = "optional"
-DEPENDS = "libnl dbus dbus-glib hal gconf-dbus wireless-tools ppp"
+DEPENDS = "libnl dbus dbus-glib hal gconf wireless-tools ppp"
 RDEPENDS = "hal wpa-supplicant iproute2 dhcp-client dhcdbd"
 
 SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/NetworkManager/0.6/NetworkManager-${PV}.tar.bz2 \
index 737d954..f41449c 100644 (file)
@@ -3,10 +3,10 @@ SECTION = "network/misc"
 LICENSE = "GPL"
 HOMEPAGE = "http://www.gnome.org"
 PRIORITY = "optional"
-DEPENDS = "libnl dbus dbus-glib libhal-nm libgpewidget gnome-keyring gconf-dbus wireless-tools libglade"
+DEPENDS = "libnl dbus dbus-glib libhal-nm libgpewidget gnome-keyring gconf wireless-tools libglade"
 RDEPENDS = "wpa-supplicant iproute2 dhcdbd gnome-keyring hicolor-icon-theme"
 
-PR = "r5"
+PR = "r6"
 
 SRC_URI="http://www.handhelds.org/~mmp/files/NetworkManager-${PV}-gpe.tar.gz \
        file://dbus-api-fix.patch;patch=1 \
index 2bb6f95..1949d3d 100644 (file)
@@ -1,9 +1,9 @@
 DESCRIPTION = "GNOME frontend for packagekit"
 LICENSE = "GPL"
 
-DEPENDS = "packagekit libsexy gconf-dbus policykit policykit-gnome libunique gnome-menus"
+DEPENDS = "packagekit libsexy gconf policykit policykit-gnome libunique gnome-menus"
 
-PR = "r1"
+PR = "r2"
 
 inherit gnome
 
index 73710f8..1638c98 100644 (file)
@@ -1,5 +1,5 @@
 DESCRIPTION = "GNOME Mobile & Embedded Initiative"
-PR = "r1"
+PR = "r2"
 
 inherit task
 
@@ -28,7 +28,7 @@ RDEPENDS_gmae-user = " \
            avahi-utils \
            gstreamer \
            matchbox-wm matchbox-panel \
-           gconf-dbus \
+           gconf \
            gnome-vfs \
            "
 
index 98234ce..db6a2fb 100644 (file)
@@ -1,5 +1,5 @@
 DESCRIPTION = "SDK packages"
-PR = "r10"
+PR = "r11"
 LICENSE = "MIT"
 ALLOW_EMPTY = "1"
 
@@ -11,7 +11,7 @@ PACKAGES = "\
 RDEPENDS_task-sdk-x11 = "\
     atk-dev \
     cairo-dev \
-    gconf-dbus-dev \
+    gconf-dev \
     gtk+-dev \
     gtk-engines-dev \
     libsvg-cairo-dev \
@@ -50,4 +50,4 @@ RDEPENDS_task-sdk-gpe = "\
     libgpewidget-dev \
     libhandoff-dev \
     libxi-dev \
-    gconf-dbus-dev"
+    gconf-dev"
index 29c3f4d..7abb8a6 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "TinyMail is an attempt to create an E-mail framework for mobile devices"
 SECTION = "x11/utils"
 LICENSE = "LGPL"
-DEPENDS = "gtk+ glib-2.0 gnome-vfs gconf-dbus libgnomeui"
+DEPENDS = "gtk+ glib-2.0 gnome-vfs gconf libgnomeui"
 
 EXTRA_OECONF=" --disable-gnome --with-platform=gpe --with-html-component=none"
 
index 06f53d3..77c2009 100644 (file)
@@ -1,7 +1,8 @@
 DESCRIPTION = "TinyMail is an attempt to create an E-mail framework for mobile devices"
 SECTION = "x11/utils"
 LICENSE = "LGPL"
-DEPENDS = "gtk+ glib-2.0 gnome-vfs gconf-dbus libgnomeui"
+DEPENDS = "gtk+ glib-2.0 gnome-vfs gconf libgnomeui"
+PR = "r1"
 
 EXTRA_OECONF=" --disable-gnome --with-platform=gpe --with-html-component=none"
 
index 7d396fe..06cc447 100644 (file)
@@ -1,9 +1,9 @@
 DESCRIPTION = "TinyMail is an attempt to create an E-mail framework for mobile devices"
 SECTION = "x11/utils"
 LICENSE = "LGPL"
-DEPENDS = "gtk+ glib-2.0 gnome-vfs gconf-dbus libgnomeui"
+DEPENDS = "gtk+ glib-2.0 gnome-vfs gconf libgnomeui"
 PV = "0.0.5+svnr${SRCREV}"
-PR = "r3"
+PR = "r4"
 
 DEFAULT_PREFERENCE = "-1"
 
index d3f84f0..69f69a4 100644 (file)
@@ -1,8 +1,8 @@
 DESCRIPTION = "Tmut is a really small E-Mail client based on Tinymail"
 SECTION = "x11/utils"
 LICENSE = "LGPL"
-DEPENDS = "gtk+ glib-2.0 gnome-vfs gconf-dbus libtinymail"
-PR = "r0"
+DEPENDS = "gtk+ glib-2.0 gnome-vfs gconf libtinymail"
+PR = "r1"
 
 SRC_URI = "http://tinymail.org/files/tmut/releases/v1.1/v${PV}/${PN}-${PV}.tar.bz2"
 
index abe7417..11fcb0a 100644 (file)
@@ -1,9 +1,9 @@
 DESCRIPTION = "Tmut is a really small E-Mail client based on Tinymail"
 SECTION = "x11/utils"
 LICENSE = "LGPL"
-DEPENDS = "gtk+ glib-2.0 gnome-vfs gconf-dbus libtinymail"
+DEPENDS = "gtk+ glib-2.0 gnome-vfs gconf libtinymail"
 PV = "0.0.0+svnr${SRCREV}"
-PR = "r2"
+PR = "r3"
 
 DEFAULT_PREFERENCE = "-1"