oe_audit.py: Parse the full output of bitbake -s
authorHolger Hans Peter Freyther <zecke@selfish.org>
Thu, 18 Mar 2010 12:56:59 +0000 (13:56 +0100)
committerHolger Hans Peter Freyther <zecke@selfish.org>
Thu, 18 Mar 2010 12:57:47 +0000 (13:57 +0100)
Instead of being forced to manually edit we can now parse
the full output of bitbake -s.

contrib/qa/oe_audit.py

index 7e04480..905f110 100755 (executable)
@@ -11,6 +11,9 @@ def read_available(filename):
     packages = {}
 
     for line in f:
+        if line.startswith("NOTE: ") or line.startswith("Parsing .bb"):
+            continue
+
         # str.split can not be used as we have multiple whitespace
         first_space = line.find(" ")
         package = line[0:first_space]