webkit-gtk: bump to 1.1.16
authorKoen Kooi <koen@openembedded.org>
Wed, 28 Oct 2009 14:03:00 +0000 (15:03 +0100)
committerKoen Kooi <koen@openembedded.org>
Wed, 28 Oct 2009 14:03:00 +0000 (15:03 +0100)
conf/distro/include/sane-srcrevs.inc
recipes/webkit/webkit-gtk/GNUmakefile.am
recipes/webkit/webkit-gtk/configure.ac
recipes/webkit/webkit-gtk_svn.bb

index f4cb5f4..2f22a7d 100644 (file)
@@ -232,7 +232,6 @@ SRCREV_pn-u-boot-openmoko ?= "650149a53dbdd48bf6dfef90930c8ab182adb512"
 SRCREV_pn-u-boot-openmoko-devel ?= "ba029a1426bfca169572bf80d50a8b190a6b0e19"
 SRCREV_pn-usbpath ?= "3172"
 SRCREV_pn-usbpath-native ?= "3172"
-SRCREV_pn-webkit-gtk ?= "48579"
 SRCREV_pn-wlan-ng-modules ?= "1859"
 SRCREV_pn-wlan-ng-utils ?= "1859"
 SRCREV_pn-wmiconfig ?= "5394"
index 23cd7ea..89260ad 100644 (file)
@@ -74,6 +74,10 @@ global_cflags :=
 global_cxxflags :=
 corekit_cflags :=
 corekit_cppflags :=
+BUILT_SOURCES :=
+CLEANFILES :=
+DISTCLEANFILES :=
+MAINTAINERCLEANFILES :=
 
 # CFLAGS/CXXFLAGS used by WebCore and WebKit
 #
@@ -395,9 +399,13 @@ webkitgtk_cppflags += \
        -I$(top_builddir)/WebKit/gtk/webkit
 
 webkitgtk_cleanfiles += \
+       $(top_builddir)/stamp-webkitmarshal.cpp \
+       $(top_builddir)/stamp-webkitmarshal.h \
+       $(top_builddir)/stamp-webkitenumtypes.cpp \
+       $(top_builddir)/stamp-webkitenumtypes.h \
+       $(top_builddir)/Programs/GtkLauncher \
        $(top_builddir)/WebKit/gtk/docs/version.xml \
        $(top_builddir)/WebKit/gtk/docs/GNUmakefile \
-       $(top_builddir)/Programs/GtkLauncher \
        $(top_builddir)/WebKit/gtk/webkit-1.0.pc \
        $(top_builddir)/WebKit/gtk/webkit/webkitenumtypes.h \
        $(top_builddir)/WebKit/gtk/webkit/webkitversion.h
@@ -405,11 +413,58 @@ webkitgtk_cleanfiles += \
 pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA = WebKit/gtk/webkit-1.0.pc
 
-stamp_files := \
-       stamp-webkitmarshal.cpp \
-       stamp-webkitmarshal.h \
-       stamp-webkitenumtypes.cpp \
-       stamp-webkitenumtypes.h
+# Files that will be distributed
+EXTRA_DIST = \
+       $(srcdir)/gtk-doc.make \
+       WebKit/LICENSE \
+       $(javascriptcore_dist) \
+       $(webcore_dist) \
+       $(srcdir)/autotools/symbols.filter \
+       $(srcdir)/WebKit/gtk/ChangeLog \
+       $(srcdir)/WebKit/gtk/NEWS \
+       $(srcdir)/WebKit/gtk/webkitmarshal.list \
+       $(srcdir)/WebKit/gtk/docs/GNUmakefile.* \
+       $(srcdir)/WebKit/gtk/docs/webkitenvironment.xml \
+       $(srcdir)/WebKit/gtk/docs/webkitgtk-docs.sgml \
+       $(srcdir)/WebKit/gtk/docs/webkitgtk-sections.txt \
+       $(srcdir)/WebKit/gtk/docs/version.xml.in \
+       $(srcdir)/WebKit/gtk/po/* \
+       $(srcdir)/WebKit/gtk/resources/*
+
+if ENABLE_INTROSPECTION
+JSCORE_GIRSOURCES = $(srcdir)/WebKit/gtk/JSCore-1.0.gir # JSCore-1.0.gir is handwritten
+WEBKIT_GIRSOURCES = WebKit-1.0.gir
+
+$(WEBKIT_GIRSOURCES): $(JSCORE_GIRSOURCES) $(G_IR_SCANNER)
+       $(AM_V_GEN)$(G_IR_SCANNER) -v --namespace WebKit --nsversion=1.0 \
+            --include=GObject-2.0 \
+            --include=Gtk-2.0 \
+            --include=JSCore-1.0 \
+            --include=Soup-2.4 \
+            --library=webkit-1.0 \
+            --libtool="$(LIBTOOL)" \
+            --pkg gobject-2.0 \
+            --pkg gtk+-2.0 \
+            --output $@ \
+            -I$(top_srcdir)/WebKit/gtk \
+            -I$(top_builddir)/WebKit/gtk \
+            -I$(top_srcdir)/JavaScriptCore/ForwardingHeaders \
+            -I$(top_srcdir) \
+            $(webkitgtk_h_api)
+
+girdir = $(GIRDIR)
+gir_DATA = $(WEBKIT_GIRSOURCES) $(JSCORE_GIRSOURCES)
+
+typelibsdir = $(GIRTYPELIBDIR)
+typelibs_DATA = $(JSCORE_GIRSOURCES:.gir=.typelib) $(WEBKIT_GIRSOURCES:.gir=.typelib)
+
+%.typelib: %.gir $(G_IR_COMPILER)
+       $(AM_V_GEN)$(G_IR_COMPILER) $< -o $@
+
+EXTRA_DIST += $(JSCORE_GIRSOURCES)
+CLEANFILES += $(WEBKIT_GIRSOURCES) $(typelibs_DATA)
+
+endif
 
 WEBKIT_MARSHAL = $(GENSOURCES)/webkitmarshal
 WEBKIT_MARSHAL_LIST = $(top_srcdir)/WebKit/gtk/webkitmarshal.list
@@ -473,24 +528,6 @@ DerivedSources/webkitenumtypes.cpp: $(webkitgtk_h_api) GNUmakefile
        && cp xgen-gtc $@ \
        && rm -f xgen-gtc
 
-# Files that will be distributed
-EXTRA_DIST = \
-       $(srcdir)/gtk-doc.make \
-       WebKit/LICENSE \
-       $(javascriptcore_dist) \
-       $(webcore_dist) \
-       $(srcdir)/autotools/symbols.filter \
-       $(srcdir)/WebKit/gtk/ChangeLog \
-       $(srcdir)/WebKit/gtk/NEWS \
-       $(srcdir)/WebKit/gtk/webkitmarshal.list \
-       $(srcdir)/WebKit/gtk/docs/GNUmakefile.* \
-       $(srcdir)/WebKit/gtk/docs/webkitenvironment.xml \
-       $(srcdir)/WebKit/gtk/docs/webkitgtk-docs.sgml \
-       $(srcdir)/WebKit/gtk/docs/webkitgtk-sections.txt \
-       $(srcdir)/WebKit/gtk/docs/version.xml.in \
-       $(srcdir)/WebKit/gtk/po/* \
-       $(srcdir)/WebKit/gtk/resources/*
-
 # extra resource files
 resourcesdir = ${datadir}/webkit-1.0/resources
 dist_resources_DATA = \
@@ -498,11 +535,6 @@ dist_resources_DATA = \
 
 # END WEBKIT GTK+
 
-# Files that will be cleaned
-MAINTAINERCLEANFILES := $(stamp_files) $(BUILT_SOURCES) doltcompile doltlibtool
-DISTCLEANFILES := $(stamp_files) $(BUILT_SOURCES) doltcompile doltlibtool
-CLEANFILES := $(stamp_files) $(BUILT_SOURCES)
-
 # Include module makefiles
 include JavaScriptCore/GNUmakefile.am
 include WebCore/GNUmakefile.am
@@ -545,7 +577,8 @@ TEST_PROGS += Programs/unittests/testhttpbackend \
        Programs/unittests/testhittestresult \
        Programs/unittests/testwebsettings \
        Programs/unittests/testwebresource \
-       Programs/unittests/testwebdatasource
+       Programs/unittests/testwebdatasource \
+       Programs/unittests/testkeyevents
 
 # Add additional tests here
 Programs_unittests_testhttpbackend_SOURCES = WebKit/gtk/tests/testhttpbackend.c
@@ -615,8 +648,13 @@ Programs_unittests_testhittestresult_SOURCES = WebKit/gtk/tests/testhittestresul
 Programs_unittests_testhittestresult_CFLAGS = $(webkit_tests_cflags)
 Programs_unittests_testhittestresult_LDADD = $(webkit_tests_ldadd)
 
+Programs_unittests_testkeyevents_SOURCES = WebKit/gtk/tests/testkeyevents.c
+Programs_unittests_testkeyevents_CFLAGS = $(webkit_tests_cflags)
+Programs_unittests_testkeyevents_LDADD = $(webkit_tests_ldadd)
+Programs_unittests_testkeyevents_LDFLAGS = $(webkit_tests_ldflags)
+
 # Autogenerated sources
-BUILT_SOURCES := \
+BUILT_SOURCES += \
        $(javascriptcore_built_sources) \
        $(javascriptcore_built_nosources) \
        $(webcore_built_sources) \
@@ -625,10 +663,20 @@ BUILT_SOURCES := \
        $(webkitgtk_built_nosources)
 
 # Project-wide clean rules
+# Files that will be cleaned
 CLEANFILES += \
+       $(BUILT_SOURCES) \
        $(webkitgtk_cleanfiles)
 
+DISTCLEANFILES += \
+       $(CLEANFILES) \
+       $(builddir)/doltcompile \
+       $(builddir)/doltlibtool
+
 MAINTAINERCLEANFILES += \
+       $(CLEANFILES) \
+       $(builddir)/doltcompile \
+       $(builddir)/doltlibtool \
        $(srcdir)/aconfig.h.in \
        $(srcdir)/autotools/config.* \
        $(srcdir)/autotools/compile \
index fb93221..b4230fb 100644 (file)
@@ -2,7 +2,7 @@ AC_PREREQ(2.59)
 
 m4_define([webkit_major_version], [1])
 m4_define([webkit_minor_version], [1])
-m4_define([webkit_micro_version], [15])
+m4_define([webkit_micro_version], [16])
 
 # This is the version we'll be using as part of our User-Agent string
 # e.g., AppleWebKit/$(webkit_user_agent_version) ...
@@ -35,7 +35,7 @@ AC_CONFIG_SRCDIR([WebCore/config.h])
 
 dnl # Libtool library version, not to confuse with API version
 dnl # see http://www.gnu.org/software/libtool/manual/html_node/Libtool-versioning.html#Libtool-versioning
-LIBWEBKITGTK_VERSION=13:0:11
+LIBWEBKITGTK_VERSION=14:0:12
 AC_SUBST([LIBWEBKITGTK_VERSION])
 
 AM_INIT_AUTOMAKE([foreign subdir-objects tar-ustar])
@@ -411,6 +411,14 @@ AC_ARG_ENABLE(geolocation,
               [],[enable_geolocation="no"])
 AC_MSG_RESULT([$enable_geolocation])
 
+# check whether to enable MathML support
+AC_MSG_CHECKING([whether to enable MathML support])
+AC_ARG_ENABLE(mathml,
+              AC_HELP_STRING([--enable-mathml],
+                             [enable support for MathML [default=no]]),
+              [],[enable_mathml="no"])
+AC_MSG_RESULT([$enable_mathml])
+
 # check whether to enable SVG support
 AC_MSG_CHECKING([whether to enable SVG support])
 AC_ARG_ENABLE(svg,
@@ -517,7 +525,7 @@ fi
 AC_MSG_CHECKING([whether to enable Web Sockets support])
 AC_ARG_ENABLE(web_sockets,
               AC_HELP_STRING([--enable-web-sockets],
-                             [enable support for Web Sockets [default=yes]]),
+                             [enable support for Web Sockets [default=no]]),
               [],[enable_web_sockets="no"])
 AC_MSG_RESULT([$enable_web_sockets])
 
@@ -568,6 +576,38 @@ if test "$enable_jit" = "yes"; then
 fi
 AC_MSG_RESULT([$enable_jit])
 
+# GObject Introspection
+AC_MSG_CHECKING([whether to enable GObject introspection support])
+AC_ARG_ENABLE([introspection],
+  [AS_HELP_STRING([--enable-introspection],[Enable GObject introspection (default: disabled)])],
+  [],[enable_introspection=no])
+AC_MSG_RESULT([$enable_introspection])
+
+G_IR_SCANNER=
+G_IR_COMPILER=
+G_IR_GENERATE=
+GIRDIR=
+GIRTYPELIBDIR=
+
+if test "$enable_introspection" = "yes"; then
+  GOBJECT_INTROSPECTION_REQUIRED=0.6.2
+  PKG_CHECK_MODULES([INTROSPECTION],[gobject-introspection-1.0 >= $GOBJECT_INTROSPECTION_REQUIRED])
+  
+  G_IR_SCANNER="$($PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0)"
+  G_IR_COMPILER="$($PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0)"
+  G_IR_GENERATE="$($PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0)"
+  GIRDIR="$($PKG_CONFIG --variable=girdir gobject-introspection-1.0)"
+  GIRTYPELIBDIR="$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)"
+
+  AC_DEFINE([ENABLE_INTROSPECTION],[1],[Define to enable GObject introspection support])
+fi
+
+AC_SUBST([G_IR_SCANNER])
+AC_SUBST([G_IR_COMPILER])
+AC_SUBST([G_IR_GENERATE])
+AC_SUBST([GIRDIR])
+AC_SUBST([GIRTYPELIBDIR])
+
 # determine the font backend
 AC_MSG_CHECKING([the font backend to use])
 AC_ARG_WITH(font_backend,
@@ -624,7 +664,15 @@ if test "$enable_icon_database" = "yes" || \
    test "$enable_database" = "yes" || \
    test "$enable_offline_web_applications" = "yes" || \
    test "$enable_dom_storage" = "yes"; then
-   PKG_CHECK_MODULES([SQLITE3], [sqlite3 >= $SQLITE_REQUIRED_VERSION])
+   PKG_CHECK_MODULES([SQLITE3],
+                     [sqlite3 >= $SQLITE_REQUIRED_VERSION],
+                     [sqlite3_has_pkg_config=yes],
+                     [sqlite3_has_pkg_config=no])
+   if test "$sqlite3_has_pkg_config" = "no"; then
+      AC_SEARCH_LIBS([sqlite3_open16], [sqlite3],
+                     [SQLITE3_LIBS="$LIBS";SQLITE3_CFLAGS="-I $srcdir/WebKitLibraries/WebCoreSQLite3"],
+                     [AC_MSG_ERROR([SQLite3 is required to enable Database support])])
+   fi
    AC_SUBST([SQLITE3_CFLAGS])
    AC_SUBST([SQLITE3_LIBS])
 fi
@@ -648,6 +696,7 @@ if test "$enable_video" = "yes"; then
    PKG_CHECK_MODULES([GSTREAMER],
                      [gstreamer-0.10 >= $GSTREAMER_REQUIRED_VERSION
                      gstreamer-base-0.10
+                     gstreamer-pbutils-0.10
                      gstreamer-plugins-base-0.10
                      gstreamer-video-0.10])
    AC_SUBST([GSTREAMER_CFLAGS])
@@ -706,9 +755,11 @@ AM_CONDITIONAL([ENABLE_XPATH],[test "$enable_xpath" = "yes"])
 AM_CONDITIONAL([ENABLE_XSLT],[test "$enable_xslt" = "yes"])
 AM_CONDITIONAL([ENABLE_FILTERS],[test "$enable_filters" = "yes"])
 AM_CONDITIONAL([ENABLE_GEOLOCATION], [test "$enable_geolocation" = "yes"])
+AM_CONDITIONAL([ENABLE_MATHML], [test "$enable_mathml" = "yes"])
 AM_CONDITIONAL([ENABLE_RUBY],[test "$enable_ruby" = "yes"])
 AM_CONDITIONAL([ENABLE_VIDEO],[test "$enable_video" = "yes"])
 AM_CONDITIONAL([ENABLE_NOTIFICATIONS],[test "$enable_notifications" = "yes"])
+AM_CONDITIONAL([ENABLE_ORIENTATION_EVENTS],[test "$enable_orientation_events" = "yes"])
 AM_CONDITIONAL([ENABLE_SVG],[test "$enable_svg" = "yes"])
 AM_CONDITIONAL([ENABLE_SVG_ANIMATION],[test "$enable_svg_animation" = "yes"])
 AM_CONDITIONAL([ENABLE_SVG_FONTS],[test "$enable_svg_fonts" = "yes"])
@@ -724,6 +775,10 @@ AM_CONDITIONAL([SVG_FLAGS],[test "$svg_flags" = "yes"])
 AM_CONDITIONAL([HTML_FLAGS],[test "$html_flags" = "yes"])
 AM_CONDITIONAL([ENABLE_WEB_SOCKETS],[test "$enable_web_sockets" = "yes"])
 
+# Gtk conditionals
+AM_CONDITIONAL([ENABLE_INTROSPECTION],[test "$enable_introspection" = "yes"])
+
+
 AC_CONFIG_FILES([
 GNUmakefile
 WebKit/gtk/webkit-1.0.pc:WebKit/gtk/webkit.pc.in
@@ -752,6 +807,7 @@ Features:
  Filters support                                          : $enable_filters
  Geolocation support                                      : $enable_geolocation
  JavaScript debugger/profiler support                     : $enable_javascript_debugger
+ MathML support                                           : $enable_mathml
  HTML5 offline web applications support                   : $enable_offline_web_applications
  HTML5 channel messaging support                          : $enable_channel_messaging
  HTML5 client-side session and persistent storage support : $enable_dom_storage
@@ -775,6 +831,7 @@ Features:
 GTK+ configuration:
  GDK target                                               : $with_target
  Hildon UI extensions                                     : $with_hildon
+ Introspection support                                    : $enable_introspection
 "
 if test "$with_unicode_backend" = "glib"; then
    echo "     >> WARNING: the glib-based unicode backend is slow and incomplete <<"
index 64c031d..b2f2baa 100644 (file)
@@ -3,7 +3,8 @@ DEPENDS = "enchant gtk-doc-native gtk-doc gnome-keyring libsoup-2.4 curl icu lib
 
 SRCREV_FORMAT = "webcore-rwebkit"
 
-PV = "1.1.15+svnr${SRCREV}"
+SRCREV = "50081"
+PV = "1.1.16+svnr${SRCREV}"
 
 SRC_URI = "\
   svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \