gs 8.64 : fixed GNU_HASH and added checksums
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Sun, 21 Mar 2010 20:20:48 +0000 (21:20 +0100)
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Sun, 28 Mar 2010 16:16:13 +0000 (18:16 +0200)
I used TARGET_CC_ARCH += "${LDFLAGS}" because the following didn't work:
  *EXTRA_OEMAKE = "XLDFLAGS='${LDFLAGS}'" (xldflags was present in some Makefile)
  *EXTRA_OEMAKE = "LDFLAGS='${LDFLAGS}'"

recipes/gs/gs_8.64.bb

index 37f0af1..20171ca 100644 (file)
@@ -5,7 +5,7 @@ HOMEPAGE = "http://www.gnu.org/software/ghostscript/ghostscript.html"
 DEPENDS = "jpeg zlib fontconfig cups"
 PR = "r2"
 
-SRC_URI = "${DEBIAN_MIRROR}/main/g/ghostscript/ghostscript_${PV}~dfsg.orig.tar.gz \
+SRC_URI = "${DEBIAN_MIRROR}/main/g/ghostscript/ghostscript_${PV}~dfsg.orig.tar.gz;name=tarball \
            file://0001_svn_snapshot.patch;patch=1 \
            file://0002_svn_snapshot_jbig2dec.patch;patch=1 \
            file://1001_install_cjk_examples.patch;patch=1 \
@@ -18,12 +18,18 @@ SRC_URI = "${DEBIAN_MIRROR}/main/g/ghostscript/ghostscript_${PV}~dfsg.orig.tar.g
            file://2002_gs_man_fix_debian.patch;patch=1 \
            "
 
+SRC_URI[tarball.md5sum] = "e42706c2409815df5c959484080fd4a3"
+SRC_URI[tarball.sha256sum] = "cc856d33cb781cdc3383b8eb4e0f390997f8359fe144a906b84297b5d377f03d"
+
+
 S = "${WORKDIR}/ghostscript-${PV}~dfsg"
 
 inherit autotools
 
 EXTRA_OECONF = "--without-x --with-jasper --with-zlib=${STAGING_DIR_HOST}${layout_prefix}"
 
+TARGET_CC_ARCH += "${LDFLAGS}"
+
 PACKAGES += "cups-gs"
 
 do_configure() {