[hal] Create hal-info.inc and share it with the releases
authorHolger Hans Peter Freyther <zecke@openmoko.org>
Thu, 28 Aug 2008 17:20:09 +0000 (19:20 +0200)
committerHolger Hans Peter Freyther <zecke@selfish.org>
Wed, 15 Oct 2008 19:04:07 +0000 (21:04 +0200)
packages/hal/hal-info.inc [new file with mode: 0644]
packages/hal/hal-info_20070618.bb
packages/hal/hal-info_20080313.bb

diff --git a/packages/hal/hal-info.inc b/packages/hal/hal-info.inc
new file mode 100644 (file)
index 0000000..635fd0a
--- /dev/null
@@ -0,0 +1,20 @@
+DESCRIPTION = "Hardware Abstraction Layer device information"
+HOMEPAGE = "http://hal.freedesktop.org/"
+SECTION = "unknown"
+LICENSE = "GPL AFL"
+
+SRC_URI = "http://hal.freedesktop.org/releases/${PN}-${PV}.tar.gz"
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-recall --disable-video"
+
+do_configure() {
+        gnu-configize
+       libtoolize --force
+       oe_runconf
+}
+
+PACKAGE_ARCH = "all"
+FILES_${PN} += "${datadir}/hal/"
index 690dbe6..e6d50e3 100644 (file)
@@ -1,20 +1 @@
-DESCRIPTION = "Hardware Abstraction Layer device information"
-HOMEPAGE = "http://freedesktop.org/Software/hal"
-SECTION = "unknown"
-LICENSE = "GPL AFL"
-
-SRC_URI = "http://people.freedesktop.org/~david/dist/hal-info-20070618.tar.gz"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--disable-recall --disable-video"
-
-do_configure() {
-        gnu-configize
-       libtoolize --force
-       oe_runconf
-}
-
-
-PACKAGE_ARCH = "all"
-FILES_${PN} += "${datadir}/hal/"
+require hal-info.inc
index 635fd0a..e6d50e3 100644 (file)
@@ -1,20 +1 @@
-DESCRIPTION = "Hardware Abstraction Layer device information"
-HOMEPAGE = "http://hal.freedesktop.org/"
-SECTION = "unknown"
-LICENSE = "GPL AFL"
-
-SRC_URI = "http://hal.freedesktop.org/releases/${PN}-${PV}.tar.gz"
-S = "${WORKDIR}/${PN}-${PV}"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--disable-recall --disable-video"
-
-do_configure() {
-        gnu-configize
-       libtoolize --force
-       oe_runconf
-}
-
-PACKAGE_ARCH = "all"
-FILES_${PN} += "${datadir}/hal/"
+require hal-info.inc