opal: update to 3.6.4
authorKoen Kooi <koen@openembedded.org>
Tue, 21 Jul 2009 09:16:48 +0000 (11:16 +0200)
committerKoen Kooi <koen@openembedded.org>
Tue, 21 Jul 2009 09:16:48 +0000 (11:16 +0200)
conf/checksums.ini
recipes/ekiga/opal_3.6.4.bb [new file with mode: 0644]

index 57a16ba..d4b6479 100644 (file)
@@ -18186,6 +18186,10 @@ sha256=e6b48a294b35449c851c2a6ea6969041ed7f4148e92b3faa03a330b7bb5a59af
 md5=88076eeadee1351704afb2aeb3532c17
 sha256=09ffe451256fafdd74d4dc35ed153b93c81328c397d36872cca1f0104877caca
 
+[http://downloads.sourceforge.net/opalvoip/opal-3.6.4.tar.bz2]
+md5=d894c176818a33d34a04b21386798c4f
+sha256=b1fb3bad0c8581b82f0da9c69673f43ad9aed7868a7e4f2a68c6c72ed656237b
+
 [http://www.openal.org/openal_webstf/downloads/openal-0.0.8.tar.gz]
 md5=641cf53761f35ee979f3e888614797a0
 sha256=723e2c57c3cdffa7ff11f9b6b5478d6cb4af017e5a1ee7a56032969c39c1c2fe
diff --git a/recipes/ekiga/opal_3.6.4.bb b/recipes/ekiga/opal_3.6.4.bb
new file mode 100644 (file)
index 0000000..502c344
--- /dev/null
@@ -0,0 +1,29 @@
+DESCRIPTION = "Open Phone Abstraction Library, implementation of the ITU H.323 teleconferencing protocol, and successor of the openh323 library."
+LICENSE = "MPL"
+
+inherit gnome
+
+DEPENDS += " ffmpeg ptlib virtual/libsdl openldap"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/opal-${PV}.tar.bz2 \
+           file://configure.diff;patch=1 \
+          "
+
+EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
+ARM_INSTRUCTION_SET = "arm"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_configure() {
+       libtoolize --force
+       gnu-configize
+       oe_runconf
+}
+
+FILES_${PN} += "${libdir}/opal-${PV}/*/*.so ${libdir}/opal-${PV}/*/*/*.so"
+FILES_${PN}-dbg += "${libdir}/opal-${PV}/*/.debug ${libdir}/opal-${PV}/*/*/.debug"
+
+do_stage() {
+       autotools_stage_all
+}
+