hal: rm led and input .fdi files
authorGrazvydas Ignotas <notasas@gmail.com>
Sun, 8 May 2016 23:26:25 +0000 (02:26 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Sun, 8 May 2016 23:26:25 +0000 (02:26 +0300)
AFAIK those are not used by anything, they just spawn helper processes
that sit there and eat memory

hald-addon-generic-backlight is actually used by backlight widget though

recipes/hal/hal_0.5.14+git.bb

index 81e34d0..8c0fa15 100644 (file)
@@ -9,7 +9,7 @@ SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
 SRCREV = "08e7d577151227199fc7c83a4a917ea1b922b14d"
 
 PV = "0.5.14"
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
 PR_append = "+gitr${SRCREV}"
 
 EXTRA_OECONF += " --with-cpufreq=no --with-omap=no"
@@ -24,3 +24,8 @@ do_configure() {
                grep "linux\/input.h" | head -n 1 | awk -F '"' '{print $2}'`
        autotools_do_configure --with-linux-input-header=${linux_input_h}
 }
+
+do_install_append() {
+       rm -f ${D}/${datadir}/hal/fdi/policy/10osvendor/10-input-policy.fdi
+       rm -f ${D}/${datadir}/hal/fdi/policy/10osvendor/10-leds.fdi
+}