nbench-byte: added BYTEmark benchmark
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Sun, 21 Jun 2009 19:36:30 +0000 (21:36 +0200)
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Mon, 22 Jun 2009 19:58:07 +0000 (21:58 +0200)
BYTE Magazine's native benchmarks (also called BYTEmark) designed to
expose the capabilities of a system's CPU, FPU and memory system.

http://www.tux.org/~mayer/linux/

Recipe from old Atmel overlay.

recipes/nbench-byte/nbench-byte/nbench_32bits.patch [new file with mode: 0644]
recipes/nbench-byte/nbench-byte_2.2.3.bb [new file with mode: 0644]

diff --git a/recipes/nbench-byte/nbench-byte/nbench_32bits.patch b/recipes/nbench-byte/nbench-byte/nbench_32bits.patch
new file mode 100644 (file)
index 0000000..fa33d60
--- /dev/null
@@ -0,0 +1,18 @@
+diff -Nur nbench-byte-2.2.3_orig/Makefile nbench-byte-2.2.3/Makefile
+--- nbench-byte-2.2.3_orig/Makefile    2004-12-30 03:23:30.000000000 +0100
++++ nbench-byte-2.2.3/Makefile 2008-10-06 18:38:46.000000000 +0200
+@@ -119,12 +119,8 @@
+       $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
+               -c emfloat.c
+-pointer.h: pointer Makefile
+-      $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
+-              -o pointer pointer.c
+-      rm -f pointer.h
+-      if [ "4" = `./pointer` ] ; then touch pointer.h ;\
+-      else echo "#define LONG64" >pointer.h ; fi
++pointer.h: Makefile
++      touch pointer.h ;
+ misc.o: misc.h misc.c Makefile
+       $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
diff --git a/recipes/nbench-byte/nbench-byte_2.2.3.bb b/recipes/nbench-byte/nbench-byte_2.2.3.bb
new file mode 100644 (file)
index 0000000..4a5fa24
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "BYTE Magazine's native benchmarks (also called BYTEmark) \
+designed to expose the capabilities of a system's CPU, FPU, \
+and memory system."
+HOMEPAGE = "http://www.tux.org/~mayer/linux/"
+LICENSE = "freely distributable"
+SECTION = "console/utils"
+
+SRC_URI = "http://www.tux.org/~mayer/linux/${PN}-${PV}.tar.gz \
+           file://nbench_32bits.patch;patch=1"
+
+do_compile() {
+       oe_runmake
+}
+
+do_install () {
+       install -d ${D}${bindir}
+       install -m 0644 NNET.DAT ${D}${bindir}/
+       install -m 0755 nbench ${D}${bindir}/
+}