libmusicbrainz: Add version 3.0.2 and fix link error
authorHolger Hans Peter Freyther <zecke@selfish.org>
Tue, 25 Aug 2009 10:47:57 +0000 (18:47 +0800)
committerHolger Hans Peter Freyther <zecke@selfish.org>
Tue, 25 Aug 2009 10:59:09 +0000 (12:59 +0200)
With gcc 4.3 stdc++ symbols leak into the library. One way to
solve it is to use a custom linker script, another one is to
just point gcc to the c++ library. The second option is used
here right now.

conf/checksums.ini
recipes/musicbrainz/libmusicbrainz.inc [new file with mode: 0644]
recipes/musicbrainz/libmusicbrainz_3.0.1.bb
recipes/musicbrainz/libmusicbrainz_3.0.2.bb [new file with mode: 0644]

index f0fc4bb..57b86c5 100644 (file)
@@ -14286,6 +14286,10 @@ sha256=c6629c4bed428f9df3f89efc065b2d96f05eba36286532ebe8b8e404022371a0
 md5=d42110ae548dae1eea73e83b03a1a936
 sha256=243311225a6bdcee065aaabc63334086cdd4298f13def45c7e798201f88d08cc
 
+[ftp://ftp.musicbrainz.org/pub/musicbrainz/libmusicbrainz-3.0.2.tar.gz]
+md5=648ecd43f7b80852419aaf73702bc23f
+sha256=b9a35e56826239add731cf083108cbc313d4a2d1770e6f5006966daa66a21eda
+
 [ftp://ftp.debian.org/debian/pool/main/libn/libnet0/libnet0_1.0.2a.orig.tar.gz]
 md5=bf4983ea440542f3ec019cc1bb6ca87d
 sha256=cf6bf75d590884fa9d0725d4d86afa93211e29cf0c5f333a60bb4e4eb347dc29
diff --git a/recipes/musicbrainz/libmusicbrainz.inc b/recipes/musicbrainz/libmusicbrainz.inc
new file mode 100644 (file)
index 0000000..64a7f50
--- /dev/null
@@ -0,0 +1,19 @@
+DEFAULT_PREFERENCE = "-1"
+
+DESCRIPTION = "The MusicBrainz client is a library which can be built into other programs. \
+It allows you to access the data held on the MusicBrainz server."
+HOMEPAGE = "http://musicbrainz.org"
+LICENSE = "LGPL"
+DEPENDS = "expat neon"
+
+SRC_URI = "ftp://ftp.musicbrainz.org/pub/musicbrainz/libmusicbrainz-${PV}.tar.gz"
+
+inherit cmake pkgconfig
+
+# Fight a compiler/link bug that leaks too many c++ symbols
+TARGET_LDFLAGS += " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib "
+
+do_stage() {
+       autotools_stage_all
+}
+
index e01695e..bd54419 100644 (file)
@@ -1,16 +1 @@
-DEFAULT_PREFERENCE = "-1"
-
-DESCRIPTION = "The MusicBrainz client is a library which can be built into other programs. \
-It allows you to access the data held on the MusicBrainz server."
-HOMEPAGE = "http://musicbrainz.org"
-LICENSE = "LGPL"
-DEPENDS = "expat neon"
-
-SRC_URI = "http://ftp.musicbrainz.org/pub/musicbrainz/libmusicbrainz-${PV}.tar.gz"
-
-inherit cmake pkgconfig
-
-do_stage() {
-       autotools_stage_all
-}
-
+require ${PN}.inc
diff --git a/recipes/musicbrainz/libmusicbrainz_3.0.2.bb b/recipes/musicbrainz/libmusicbrainz_3.0.2.bb
new file mode 100644 (file)
index 0000000..bd54419
--- /dev/null
@@ -0,0 +1 @@
+require ${PN}.inc