eglibc_2.9: Adjust sed script to insert _begin in newer linker scripts.
authorKhem Raj <raj.khem@gmail.com>
Wed, 15 Jul 2009 21:42:02 +0000 (14:42 -0700)
committerKhem Raj <raj.khem@gmail.com>
Wed, 15 Jul 2009 21:42:02 +0000 (14:42 -0700)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
recipes/eglibc/eglibc_2.9.bb
recipes/eglibc/files/eglibc_adjust_begin_insertion.patch [new file with mode: 0644]

index b3786d3..7ab4815 100644 (file)
@@ -4,11 +4,12 @@ DEPENDS += "gperf-native"
 DEFAULT_PREFERENCE = "1"
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/eglibc-svn"
 PV = "2.9"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
 SVN_REV="7430"
 EGLIBC_BRANCH="eglibc-2_9"
 SRC_URI = "svn://svn.eglibc.org/branches;module=eglibc-2_9;rev=${SVN_REV};proto=svn \
            file://eglibc-svn-arm-lowlevellock-include-tls.patch;patch=1 \
+           file://eglibc_adjust_begin_insertion.patch;patch=1 \
            file://etc/ld.so.conf \
            file://generate-supported.mk"
 S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
diff --git a/recipes/eglibc/files/eglibc_adjust_begin_insertion.patch b/recipes/eglibc/files/eglibc_adjust_begin_insertion.patch
new file mode 100644 (file)
index 0000000..8f05cc0
--- /dev/null
@@ -0,0 +1,13 @@
+Index: libc/elf/Makefile
+===================================================================
+--- libc.orig/elf/Makefile     2009-07-15 14:37:34.000000000 -0700
++++ libc/elf/Makefile  2009-07-15 14:37:47.000000000 -0700
+@@ -305,7 +305,7 @@
+                 $(LDFLAGS-rtld) -Wl,-z,defs -Wl,--verbose 2>&1 |      \
+                 LC_ALL=C \
+                 sed -e '/^=========/,/^=========/!d;/^=========/d'    \
+-                    -e 's/\. = 0 + SIZEOF_HEADERS;/& _begin = . - SIZEOF_HEADERS;/' \
++                    -e 's/\. = .* + SIZEOF_HEADERS;/& _begin = . - SIZEOF_HEADERS;/' \
+                 > $@.lds
+       $(LINK.o) -nostdlib -nostartfiles -shared -o $@                 \
+                 $(LDFLAGS-rtld) -Wl,-z,defs $(z-now-$(bind-now))      \