python-efl cvs generate .edj files and ship 'em
authorMichael Lauer <mickey@vanille-media.de>
Sun, 13 Jan 2008 23:28:42 +0000 (23:28 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Sun, 13 Jan 2008 23:28:42 +0000 (23:28 +0000)
packages/python/python-edje_cvs.bb
packages/python/python-efl-examples.bb
packages/python/python-efl.inc
packages/python/python-emotion_cvs.bb
packages/python/python-epsilon_cvs.bb
packages/python/python-evas_cvs.bb

index 1ca047e..1205e7e 100644 (file)
@@ -1,5 +1,4 @@
 require python-efl.inc
 DEPENDS += "edje python-evas"
-
-PR = "r4"
+PR = "r5"
 
index 5648033..0a4e320 100644 (file)
@@ -1,7 +1,10 @@
 DESCRIPTION = "Python Examples for the Enlightenment Foundation Libraries"
 LICENSE = "MIT"
 SECTION = "devel/python"
-RDEPENDS = "python-efl python-ecore-examples python-emotion-examples python-edje-examples python-epsilon-examples"
-PR = "ml1"
+RDEPENDS = "\
+  python-efl python-ecore-examples python-emotion-examples python-edje-examples python-epsilon-examples \
+  python-math python-textutils \
+"
+PR = "ml2"
 
 ALLOW_EMPTY = "1"
index e54cfff..e6cc62d 100644 (file)
@@ -15,6 +15,14 @@ S = "${WORKDIR}/${PN}"
 
 do_install_append() {
        if [ -e examples ]; then
+               for i in `find examples -name "*.edc"`; do
+                       pushd `dirname $i`
+                       echo "Generating .edj file for $i..."
+                       edje_cc `basename $i`
+                       echo "Removing sources in this directory..."
+                       rm -f *.edc *.png *.ttf *.jpeg
+                       popd
+               done
                install -d ${D}${datadir}/${PN}/
                cp -a examples ${D}${datadir}/${PN}/
                find ${D}${datadir}/${PN}/examples -name "CVS" | xargs rm -rf
index 0d0ce22..d3f5109 100644 (file)
@@ -1,4 +1,3 @@
 require python-efl.inc
 DEPENDS += "emotion python-evas"
-
-PR = "r3"
+PR = "r4"
index 1e77886..204dd95 100644 (file)
@@ -1,3 +1,3 @@
 require python-efl.inc
 DEPENDS += "epsilon python-ecore"
-PR = "r3"
+PR = "r4"
index a24b50a..e0de456 100644 (file)
@@ -1,7 +1,6 @@
 require python-efl.inc
 DEPENDS += "evas"
-
-PR = "r3"
+PR = "r4"
 
 do_stage() {
        distutils_stage_all