oprofile: move common stuff to oprofile.inc
authorMarcin Juszkiewicz <hrw@openembedded.org>
Fri, 5 Dec 2008 14:05:26 +0000 (15:05 +0100)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Fri, 5 Dec 2008 14:59:21 +0000 (15:59 +0100)
packages/oprofile/oprofile.inc [new file with mode: 0644]
packages/oprofile/oprofile_0.9.2.bb
packages/oprofile/oprofile_0.9.3.bb
packages/oprofile/oprofile_0.9.4.bb
packages/oprofile/oprofile_cvs.bb

diff --git a/packages/oprofile/oprofile.inc b/packages/oprofile/oprofile.inc
new file mode 100644 (file)
index 0000000..45bf256
--- /dev/null
@@ -0,0 +1,37 @@
+SECTION = "devel"
+DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
+of profiling all running code at low overhead."
+LICENSE = "GPL"
+DEPENDS = "popt binutils"
+
+S = "${WORKDIR}/oprofile-${PV}"
+
+inherit autotools
+
+# NOTE: this disables the build of the kernel modules.
+# Should add the oprofile kernel modules, for those with 2.4
+# kernels, as a seperate .oe file.
+EXTRA_OECONF = "--with-kernel-support \
+               --without-x \
+               --disable-werror "
+
+do_configure () {
+       cp ${WORKDIR}/acinclude.m4 ${S}/
+       autotools_do_configure
+}
+# Available config options
+#  --enable-abi                 enable abi portability code (default is disabled)
+#  --enable-pch                 enable precompiled header (default is disabled)
+#  --enable-gcov                enable option for gcov coverage testing (default is disabled)
+#  --disable-werror            disable -Werror flag (default is enabled for non-release)
+#  --disable-optimization      disable optimization flags (default is enabled)
+#  --with-kernel-support        Use 2.6 kernel (no kernel source tree required)
+#  --with-linux=dir             Path to Linux source tree
+#  --with-module-dir=dir        Path to module installation directory
+#  --with-extra-includes=DIR    add extra include paths
+#  --with-extra-libs=DIR        add extra library paths
+#  --with-x                use the X Window System
+#  --with-qt-dir           where the root of Qt is installed
+#  --with-qt-includes      where the Qt includes are.
+#  --with-qt-libraries     where the Qt library is installed.
+
index e64aa10..57e17e5 100644 (file)
@@ -1,39 +1,8 @@
-SECTION = "devel"
-DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
-of profiling all running code at low overhead."
-LICENSE = "GPL"
-DEPENDS = "popt binutils"
+require oprofile.inc
+
+PR = "r1"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
           file://no_arm_mapping_syms.patch;patch=1 \
            file://opcontrol_bashisms.patch;patch=1 \
           file://acinclude.m4"
-S = "${WORKDIR}/oprofile-${PV}"
-
-inherit autotools
-
-# NOTE: this disables the build of the kernel modules.
-# Should add the oprofile kernel modules, for those with 2.4
-# kernels, as a seperate .oe file.
-EXTRA_OECONF = "--with-kernel-support \
-               --without-x"
-
-do_configure () {
-       cp ${WORKDIR}/acinclude.m4 ${S}/
-       autotools_do_configure
-}
-# Available config options
-#  --enable-abi                 enable abi portability code (default is disabled)
-#  --enable-pch                 enable precompiled header (default is disabled)
-#  --enable-gcov                enable option for gcov coverage testing (default is disabled)
-#  --disable-werror            disable -Werror flag (default is enabled for non-release)
-#  --disable-optimization      disable optimization flags (default is enabled)
-#  --with-kernel-support        Use 2.6 kernel (no kernel source tree required)
-#  --with-linux=dir             Path to Linux source tree
-#  --with-module-dir=dir        Path to module installation directory
-#  --with-extra-includes=DIR    add extra include paths
-#  --with-extra-libs=DIR        add extra library paths
-#  --with-x                use the X Window System
-#  --with-qt-dir           where the root of Qt is installed
-#  --with-qt-includes      where the Qt includes are.
-#  --with-qt-libraries     where the Qt library is installed.
index 7ffcec3..1553c10 100644 (file)
@@ -1,11 +1,8 @@
-SECTION = "devel"
-DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
-of profiling all running code at low overhead."
-LICENSE = "GPL"
-DEPENDS = "popt binutils"
-RDEPENDS = "binutils-symlinks"
-RRECOMMENDS = "kernel-vmlinux"
-PR = "r8"
+require oprofile.inc
+
+RDEPENDS += "binutils-symlinks"
+RRECOMMENDS += "kernel-vmlinux"
+PR = "r9"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
            file://armv6_fix.patch;patch=1 \
@@ -16,33 +13,3 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
            file://gcc43x-fix.patch;patch=1 \
            file://armv7a.diff;patch=1 \
            file://acinclude.m4"
-
-S = "${WORKDIR}/oprofile-${PV}"
-
-inherit autotools
-
-# NOTE: this disables the build of the kernel modules.
-# Should add the oprofile kernel modules, for those with 2.4
-# kernels, as a seperate .oe file.
-EXTRA_OECONF = "--with-kernel-support \
-               --without-x"
-
-do_configure () {
-       cp ${WORKDIR}/acinclude.m4 ${S}/
-       autotools_do_configure
-}
-# Available config options
-#  --enable-abi                 enable abi portability code (default is disabled)
-#  --enable-pch                 enable precompiled header (default is disabled)
-#  --enable-gcov                enable option for gcov coverage testing (default is disabled)
-#  --disable-werror            disable -Werror flag (default is enabled for non-release)
-#  --disable-optimization      disable optimization flags (default is enabled)
-#  --with-kernel-support        Use 2.6 kernel (no kernel source tree required)
-#  --with-linux=dir             Path to Linux source tree
-#  --with-module-dir=dir        Path to module installation directory
-#  --with-extra-includes=DIR    add extra include paths
-#  --with-extra-libs=DIR        add extra library paths
-#  --with-x                use the X Window System
-#  --with-qt-dir           where the root of Qt is installed
-#  --with-qt-includes      where the Qt includes are.
-#  --with-qt-libraries     where the Qt library is installed.
index f8fb744..63f4093 100644 (file)
@@ -1,11 +1,8 @@
-SECTION = "devel"
-DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
-of profiling all running code at low overhead."
-LICENSE = "GPL"
-DEPENDS = "popt binutils"
-RDEPENDS = "binutils-symlinks"
-RRECOMMENDS = "kernel-vmlinux"
-PR = "r0"
+require oprofile.inc
+
+RDEPENDS += "binutils-symlinks"
+RRECOMMENDS += "kernel-vmlinux"
+PR = "r1"
 
 SRC_URI = "\
        ${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
@@ -14,18 +11,6 @@ SRC_URI = "\
        file://acinclude.m4 \
        "
 
-inherit autotools
-
-EXTRA_OECONF = " \
-       --with-kernel-support \
-       --without-x \
-       "
-
-do_configure () {
-       cp ${WORKDIR}/acinclude.m4 ${S}/
-       autotools_do_configure
-}
-
 do_stage () {
        # As of 0.9.4 there is a libopagent library to compile and link against.
        autotools_stage_all
index 786e704..083134b 100644 (file)
@@ -1,44 +1,14 @@
+require oprofile.inc
+
 PV = "0.9.3+cvs${SRCDATE}"
-PR = "r0"
-SECTION = "devel"
-DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
-of profiling all running code at low overhead."
-LICENSE = "GPL"
-DEPENDS = "popt binutils"
-RDEPENDS = "binutils-symlinks"
+PR = "r1"
+
+RDEPENDS += "binutils-symlinks"
 
 DEFAULT_PREFERENCE = "-1"
 
 SRC_URI = "cvs://anonymous@oprofile.cvs.sourceforge.net/cvsroot/oprofile;module=oprofile \
            file://opstart.patch;patch=1 \
           file://acinclude.m4"
-S = "${WORKDIR}/oprofile"
 
-inherit autotools
-
-# NOTE: this disables the build of the kernel modules.
-# Should add the oprofile kernel modules, for those with 2.4
-# kernels, as a seperate .oe file.
-EXTRA_OECONF = "--with-kernel-support \
-               --without-x \
-               --disable-werror "
-
-do_configure () {
-       cp ${WORKDIR}/acinclude.m4 ${S}/
-       autotools_do_configure
-}
-# Available config options
-#  --enable-abi                 enable abi portability code (default is disabled)
-#  --enable-pch                 enable precompiled header (default is disabled)
-#  --enable-gcov                enable option for gcov coverage testing (default is disabled)
-#  --disable-werror            disable -Werror flag (default is enabled for non-release)
-#  --disable-optimization      disable optimization flags (default is enabled)
-#  --with-kernel-support        Use 2.6 kernel (no kernel source tree required)
-#  --with-linux=dir             Path to Linux source tree
-#  --with-module-dir=dir        Path to module installation directory
-#  --with-extra-includes=DIR    add extra include paths
-#  --with-extra-libs=DIR        add extra library paths
-#  --with-x                use the X Window System
-#  --with-qt-dir           where the root of Qt is installed
-#  --with-qt-includes      where the Qt includes are.
-#  --with-qt-libraries     where the Qt library is installed.
+S = "${WORKDIR}/oprofile"