base-files: use inputrc from debian
authorGrazvydas Ignotas <notasas@gmail.com>
Sun, 19 Oct 2014 20:59:20 +0000 (23:59 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Sun, 19 Oct 2014 21:07:28 +0000 (00:07 +0300)
recipes/base-files/base-files/filesystems
recipes/base-files/base-files/omap3-pandora/inputrc [new file with mode: 0644]
recipes/base-files/base-files_3.0.14.bb

diff --git a/recipes/base-files/base-files/omap3-pandora/inputrc b/recipes/base-files/base-files/omap3-pandora/inputrc
new file mode 100644 (file)
index 0000000..5253889
--- /dev/null
@@ -0,0 +1,66 @@
+# /etc/inputrc - global inputrc for libreadline
+# See readline(3readline) and `info rluserman' for more information.
+
+# Be 8 bit clean.
+set input-meta on
+set output-meta on
+
+# To allow the use of 8bit-characters like the german umlauts, uncomment
+# the line below. However this makes the meta key not work as a meta key,
+# which is annoying to those which don't need to type in 8-bit characters.
+
+# set convert-meta off
+
+# try to enable the application keypad when it is called.  Some systems
+# need this to enable the arrow keys.
+# set enable-keypad on
+
+# see /usr/share/doc/bash/inputrc.arrows for other codes of arrow keys
+
+# do not bell on tab-completion
+# set bell-style none
+# set bell-style visible
+
+# some defaults / modifications for the emacs mode
+$if mode=emacs
+
+# allow the use of the Home/End keys
+"\e[1~": beginning-of-line
+"\e[4~": end-of-line
+
+# allow the use of the Delete/Insert keys
+"\e[3~": delete-char
+"\e[2~": quoted-insert
+
+# mappings for "page up" and "page down" to step to the beginning/end
+# of the history
+# "\e[5~": beginning-of-history
+# "\e[6~": end-of-history
+
+# alternate mappings for "page up" and "page down" to search the history
+# "\e[5~": history-search-backward
+# "\e[6~": history-search-forward
+
+# mappings for Ctrl-left-arrow and Ctrl-right-arrow for word moving
+"\e[1;5C": forward-word
+"\e[1;5D": backward-word
+"\e[5C": forward-word
+"\e[5D": backward-word
+"\e\e[C": forward-word
+"\e\e[D": backward-word
+
+$if term=rxvt
+"\e[8~": end-of-line
+"\eOc": forward-word
+"\eOd": backward-word
+$endif
+
+# for non RH/Debian xterm, can't hurt for RH/Debian xterm
+# "\eOH": beginning-of-line
+# "\eOF": end-of-line
+
+# for freebsd console
+# "\e[H": beginning-of-line
+# "\e[F": end-of-line
+
+$endif
index a698a18..64c514a 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Miscellaneous files for the base system."
 SECTION = "base"
 PRIORITY = "required"
-PR = "r93"
+PR = "r94"
 LICENSE = "GPL"
 
 SRC_URI = " \
@@ -42,15 +42,13 @@ dirs755 = "/bin /boot /dev ${sysconfdir} ${sysconfdir}/default \
           ${localstatedir}/volatile/lock/subsys \
           ${localstatedir}/volatile/log \
           ${localstatedir}/volatile/run \
-          /mnt /media /media/card /media/cf /media/net /media/ram \
-          /media/union /media/realroot /media/hdd \
-          /media/mmc1"
+          /mnt /media /media/ram"
 
 dirs755_micro = "/dev /proc /sys ${sysconfdir}"
 dirs2775_micro = ""
 dirs1777_micro = "/tmp"
 
-media = "card cf net ram"
+media = "ram"
 media_micro = ""
 
 volatiles = "cache run log lock tmp"