minicom: fix compile error due to conflicting function names
authormd <md@freiheit.com>
Mon, 8 Jun 2009 17:31:47 +0000 (19:31 +0200)
committermd <md@freiheit.com>
Mon, 8 Jun 2009 17:31:47 +0000 (19:31 +0200)
- the `getline()' function used in minicom.c may have been defined in stdio.h if __USE_GNU is defined
- as a fix that function name is redefined within minicom.c

recipes/minicom/minicom-2.3/rename-conflicting-functions.patch [new file with mode: 0644]
recipes/minicom/minicom_2.3.bb

diff --git a/recipes/minicom/minicom-2.3/rename-conflicting-functions.patch b/recipes/minicom/minicom-2.3/rename-conflicting-functions.patch
new file mode 100644 (file)
index 0000000..c344203
--- /dev/null
@@ -0,0 +1,13 @@
+--- minicom-2.3/src/minicom.c-orig     2009-06-08 14:49:07.000000000 +0200
++++ minicom-2.3/src/minicom.c  2009-06-08 14:50:23.000000000 +0200
+@@ -63,6 +63,10 @@
+ }
+ #endif /*DEBUG*/
++#ifdef __USE_GNU
++#define getline minicom_getline
++#endif
++
+ /*
+  * Sub - menu's.
+  */
index 5b32401..736ac84 100644 (file)
@@ -2,6 +2,7 @@ SECTION = "console/network"
 DEPENDS = "ncurses"
 LICENSE = "GPL"
 SRC_URI = "http://alioth.debian.org/frs/download.php/2332/minicom-${PV}.tar.gz \
+       file://rename-conflicting-functions.patch;patch=1 \
        "
 
 inherit autotools gettext