mono-2.4.2.3: Fix compilation issues.
authorKhem Raj <raj.khem@gmail.com>
Fri, 16 Oct 2009 18:25:08 +0000 (11:25 -0700)
committerKhem Raj <raj.khem@gmail.com>
Fri, 16 Oct 2009 18:29:36 +0000 (11:29 -0700)
* Disable parallel make, mono does not like it.
* Add a patch to get mono cross compile for x86 target.
* add mono_cv_sizeof_sunpath to site files, becasue
  previously it was called cv_mono_sizeof_sunpath

Signed-off-by: Khem Raj <raj.khem@gmail.com>
recipes/mono/mono-2.4.2.3.inc [moved from recipes/mono/mono_2.4.2.3.inc with 83% similarity]
recipes/mono/mono-2.4.2.3/mono-cross-compilation-for-amd64.patch [new file with mode: 0644]
recipes/mono/mono-mcs-intermediate_2.4.2.3.bb
recipes/mono/mono-native_2.4.2.3.bb
recipes/mono/mono_2.4.2.3.bb
site/arm-common
site/ix86-common
site/mips-linux
site/mipsel-linux
site/sh-common

similarity index 83%
rename from recipes/mono/mono_2.4.2.3.inc
rename to recipes/mono/mono-2.4.2.3.inc
index 21e5960..2625703 100644 (file)
@@ -6,7 +6,11 @@ SRC_URI = "http://ftp.novell.com/pub/mono/sources/mono/mono-2.4.2.3.tar.bz2"
 
 INC_PR = "r3"
 
-S = "${WORKDIR}/mono-2.4.2.3"
+S = "${WORKDIR}/mono-${PV}"
+
+# parallel make does not work for mono (currently)
+
+PARALLEL_MAKE = ""
 
 do_fix_dolt_libtool() {
        # look for libtool prefixed with HOST_SYS
diff --git a/recipes/mono/mono-2.4.2.3/mono-cross-compilation-for-amd64.patch b/recipes/mono/mono-2.4.2.3/mono-cross-compilation-for-amd64.patch
new file mode 100644 (file)
index 0000000..e8d91da
--- /dev/null
@@ -0,0 +1,23 @@
+This is a workaround for bug 515050
+https://bugzilla.novell.com/show_bug.cgi?id=515050#c2
+
+Real fix is something else which did not make into 2.4.2
+http://lists.ximian.com/pipermail/mono-patches/2009-June/151386.html
+http://lists.ximian.com/pipermail/mono-patches/2009-June/151387.html
+
+but we are ok with workaround its safe.
+
+-Khem
+Index: mono-2.4.2.3/mono/mini/genmdesc.pl
+===================================================================
+--- mono-2.4.2.3.orig/mono/mini/genmdesc.pl    2009-10-15 18:21:45.000000000 -0700
++++ mono-2.4.2.3/mono/mini/genmdesc.pl 2009-10-15 18:22:19.000000000 -0700
+@@ -47,7 +47,7 @@ sub load_opcodes
+               $arch_define = "TARGET_ARM";
+       }
+               
+-      $cpp .= " -D$arch_define $srcdir/mini-ops.h|";
++      $cpp .= " -DMONO_ARCH_SUPPORT_SIMD_INTRINSICS -D$arch_define $srcdir/mini-ops.h|";
+       #print "Running: $cpp\n";
+       open (OPS, $cpp) || die "Cannot execute cpp: $!";
+       while (<OPS>) {
index 258f812..92fc9f1 100644 (file)
@@ -5,7 +5,7 @@
 # package in step 2.
 # See http://www.mono-project.com/Mono:ARM
 
-require mono_2.4.2.3.inc
+require mono-${PV}.inc
 require mono-mcs-intermediate.inc
 
 DEFAULT_PREFERENCE = "-1"
@@ -13,5 +13,3 @@ DEFAULT_PREFERENCE = "-1"
 SRC_URI += ""
 
 PR = "${INC_PR}.1"
-
-
index 44ac053..7974e95 100644 (file)
@@ -1,4 +1,4 @@
-require mono_2.4.2.3.inc
+require mono-${PV}.inc
 DEPENDS = "glib-2.0-native perl-native"
 
 PR = "${INC_PR}.1"
index e1f1968..e18a4e7 100644 (file)
@@ -1,4 +1,4 @@
-require mono_2.4.2.3.inc
+require mono-${PV}.inc
 
 DEPENDS = "mono-native mono-mcs-intermediate glib-2.0 perl-native"
 
@@ -11,7 +11,9 @@ ARM_INSTRUCTION_SET = "arm"
 
 SRC_URI += "file://configure.patch;patch=1\
            file://mini-arm.patch;patch=1\
-            file://0001-remove-docs-dir-from-build.patch;patch=1"
+            file://0001-remove-docs-dir-from-build.patch;patch=1 \
+            file://mono-cross-compilation-for-amd64.patch;patch=1 \
+           "
 
 # Per http://www.mono-project.com/Mono:ARM
 EXTRA_OECONF += " --disable-mcs-build "
index 39eb30b..fd602bf 100644 (file)
@@ -134,6 +134,7 @@ ac_cv_lib_png_png_create_info_struct=${ac_cv_lib_png_png_create_info_struct=yes}
 
 # mono
 cv_mono_sizeof_sunpath=108
+mono_cv_sizeof_sunpath=108
 
 # mysql
 mysql_cv_func_atomic_sub=${mysql_cv_func_atomic_sub=no}
index 3995e67..134890d 100644 (file)
@@ -155,6 +155,7 @@ with_broken_putenv=${with_broken_putenv=no}
 
 # mono
 cv_mono_sizeof_sunpath=108
+mono_cv_sizeof_sunpath=108
 
 # mysql
 mysql_cv_func_atomic_sub=${mysql_cv_func_atomic_sub=yes}
index 43f4aef..e00c175 100644 (file)
@@ -111,5 +111,6 @@ ac_cv_func_posix_getpwnam_r=${ac_cv_func_posix_getpwnam_r=yes}
 
 # mono
 cv_mono_sizeof_sunpath=108
+mono_cv_sizeof_sunpath=108
 mono_cv_uscore=${mono_cv_uscore=no}
 
index bf82d4e..042e09a 100644 (file)
@@ -115,5 +115,6 @@ ac_cv_func_posix_getpwnam_r=${ac_cv_func_posix_getpwnam_r=yes}
 
 # mono
 cv_mono_sizeof_sunpath=108
+mono_cv_sizeof_sunpath=108
 mono_cv_uscore=${mono_cv_uscore=no}
 
index 02ea89d..dd955d9 100644 (file)
@@ -227,6 +227,7 @@ bash_cv_func_sigsetjmp=${bash_cv_func_sigsetjmp=missing}
 
 # mono
 cv_mono_sizeof_sunpath=108
+mono_cv_sizeof_sunpath=108
 
 # mysql
 mysql_cv_func_atomic_sub=${mysql_cv_func_atomic_sub=no}