xerces-c 2.8.0 make it compile for the target architecture *cough*
authorMichael Lauer <mickey@vanille-media.de>
Sat, 12 Jan 2008 15:10:04 +0000 (15:10 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Sat, 12 Jan 2008 15:10:04 +0000 (15:10 +0000)
packages/xerces-c/xerces-c_2.8.0.bb

index 9f911bd..4f72e9d 100644 (file)
@@ -1,18 +1,24 @@
 DESCRIPTION = "Xerces-c is a validating xml parser written in C++"
+HOMEPAGE = "http://xerces.apache.org/xerces-c/"
 SECTION =  "libs"
 PRIORITY = "optional"
 LICENSE = "MIT"
+PR = "r1"
 
 SRC_URI = "http://mirror.serversupportforum.de/apache/xerces/c/sources/xerces-c-src_2_8_0.tar.gz"
 S = "${WORKDIR}/xerces-c-src_2_8_0/src/xercesc"
 
-inherit pkgconfig
+inherit autotools pkgconfig
 
 CCACHE = ""
 export XERCESCROOT="${WORKDIR}/xerces-c-src_2_8_0"
+export cross_compiling = "yes"
 
 do_configure() {
-       ./runConfigure -plinux -c"${BUILD_CC}" -x"${BUILD_CXX}" -minmem -nsocket -tnative -rpthread -P${D}${prefix}
+       ./runConfigure -plinux -c"${CC}" -x"${CXX}" -minmem -nsocket -tnative -rpthread -P${D}${prefix} \
+                    -C--build=${BUILD_SYS} \
+                    -C--host=${HOST_SYS} \
+                    -C--target=${TARGET_SYS} \
 }
 
 do_compile() {