wpa-gui: Add 0.6.10.
authorDavid-John Willis <John.Willis@Distant-earth.com>
Tue, 16 Mar 2010 15:30:51 +0000 (15:30 +0000)
committerDavid-John Willis <John.Willis@Distant-earth.com>
Thu, 8 Apr 2010 07:19:45 +0000 (08:19 +0100)
recipes/wpa-supplicant/wpa-gui_0.6.10.bb [new file with mode: 0644]

diff --git a/recipes/wpa-supplicant/wpa-gui_0.6.10.bb b/recipes/wpa-supplicant/wpa-gui_0.6.10.bb
new file mode 100644 (file)
index 0000000..a327f0b
--- /dev/null
@@ -0,0 +1,53 @@
+DESCRIPTION = "Qt interface for choosing which configured network to connect \
+to. It also provides a method for browsing 802.11 SSID scan results, an event \
+history log of messages generated by wpa_supplicant, and a method to add or \
+edit wpa_supplicant networks."
+SECTION = "network"
+LICENSE = "GPL BSD"
+HOMEPAGE = "http://hostap.epitest.fi/wpa_supplicant/"
+DEPENDS = "librsvg-native imagemagick-native"
+RDEPENDS = "wpa-supplicant"
+RRECOMMENDS = "${LIBC}-gconv-utf-16"
+PR = "r0"
+
+SRC_URI = "http://hostap.epitest.fi/releases/wpa_supplicant-${PV}.tar.gz;name=wpa_supplicant-${PV} \
+         file://icons.patch;patch=1 \
+         file://session_manager.patch;patch=1 "
+
+SRC_URI_append_shr = "file://desktop.patch;patch=1 \
+                     file://style"
+                     
+# Checksums
+SRC_URI[wpa_supplicant-0.6.10.md5sum] = "8985b1030d753e5f74f8acfc34e591bb"
+SRC_URI[wpa_supplicant-0.6.10.sha256sum] = "ac27c69c26e3f4e06fba13e0dc8e1c7ed7b0012a95263bcfcf0f39be8059f2fd"
+
+
+S = "${WORKDIR}/wpa_supplicant-${PV}/wpa_supplicant/wpa_gui-qt4"
+
+inherit qt4x11
+ARM_INSTRUCTION_SET = "arm"
+
+do_compile_append() {
+       oe_runmake -C ${S}/icons
+}
+
+do_install () {
+       install -d ${D}${bindir}
+       install -d ${D}${datadir}/wpa_gui
+       install -d ${D}${datadir}/applications
+       install -d ${D}${datadir}/pixmaps
+       install -m 644 icons/hicolor/128x128/apps/wpa_gui.png ${D}${datadir}/pixmaps
+       install -m 755 wpa_gui ${D}/${bindir}
+       install -m 644 wpa_gui.desktop ${D}/${datadir}/applications
+}
+
+do_install_append_shr() {
+       install -m 644 ${WORKDIR}/style ${D}/${datadir}/wpa_gui
+}
+
+FILES_${PN} = "/usr/share/pixmaps/wpa_gui.png \
+               /usr/share/wpa_gui/style \
+               /usr/bin/wpa_gui \
+               /usr/share/applications/wpa_gui.desktop"
+
+FILES_${PN}_append_shr = " /usr/share/wpa_gui/style"