Add my tools to forward the Serial from the Neo to my PC and provide a PTY on the PC
authorHolger Freyther <zecke@selfish.org>
Mon, 17 Mar 2008 16:00:48 +0000 (16:00 +0000)
committerHolger Freyther <zecke@selfish.org>
Mon, 17 Mar 2008 16:00:48 +0000 (16:00 +0000)
conf/distro/include/sane-srcrevs.inc
packages/openmoko-tools/pty-forward-native.bb [new file with mode: 0644]
packages/openmoko-tools/serial-forward.bb [new file with mode: 0644]

index 5e4f717..dc5961c 100644 (file)
@@ -141,6 +141,7 @@ SRCREV_pn-opkg ?= "4142"
 SRCREV_pn-opkg-native ?= "4142"
 SRCREV_pn-oprofileui ?= "160"
 SRCREV_pn-psplash ?= "249"
+SRCREV_pn-pty-forward-native ?= "4214"
 SRCREV_pn-pylgrim ?= "20"
 SRCREV_pn-pyneod ?= "88"
 SRCREV_pn-pyneog ?= "88"
@@ -148,6 +149,7 @@ SRCREV_pn-python-formencode = "3148"
 SRCREV_pn-python-gsmd = "127"
 SRCREV_pn-python-lightmediascanner = "68"
 SRCREV_pn-s3c24xx-gpio ?= "4130"
+SRCREV_pn-serial-forward ?= "4214"
 SRCREV_pn-settings-daemon ?= "1755"
 SRCREV_pn-sjf2410-linux-native ?= "933"
 SRCREV_pn-sphyrna ?= "45"
diff --git a/packages/openmoko-tools/pty-forward-native.bb b/packages/openmoko-tools/pty-forward-native.bb
new file mode 100644 (file)
index 0000000..972070d
--- /dev/null
@@ -0,0 +1,24 @@
+LICENSE="GPL"
+SUMMARY="Receive a forwarded serial from serial-forward and provide a PTY"
+
+SRC_URI="svn://svn.openmoko.org/developers/zecke/;module=serial_forward;proto=http"
+S = "${WORKDIR}/serial_forward"
+
+inherit native
+
+do_compile() {
+    cd ${S}
+    oe_runmake
+}
+
+do_stage() {
+    :
+}
+
+do_deploy() {
+    install -d ${DEPLOY_DIR_IMAGE}
+    install -m 0755 ${S}/pty_forward ${DEPLOY_DIR_IMAGE}/pty-forward
+}
+
+addtask deploy before do_package after do_install
+
diff --git a/packages/openmoko-tools/serial-forward.bb b/packages/openmoko-tools/serial-forward.bb
new file mode 100644 (file)
index 0000000..3cc3377
--- /dev/null
@@ -0,0 +1,15 @@
+LICENSE="GPL"
+SUMMARY="Forward a serial using TCP/IP"
+
+SRC_URI="svn://svn.openmoko.org/developers/zecke/;module=serial_forward;proto=http"
+S="${WORKDIR}/serial_forward"
+
+do_compile() {
+    cd ${S}
+    oe_runmake
+}
+
+do_install() {
+    install -d ${D}/${bindir}
+    install -m 0755 ${S}/forward ${D}/${bindir}/${PN}
+}