libexif: fix do_install and staging
authorKoen Kooi <koen@openembedded.org>
Wed, 27 Dec 2006 17:47:17 +0000 (17:47 +0000)
committerKoen Kooi <koen@openembedded.org>
Wed, 27 Dec 2006 17:47:17 +0000 (17:47 +0000)
packages/libexif/libexif_0.6.13.bb

index e8b8c65..40888df 100644 (file)
@@ -8,12 +8,10 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/libexif/libexif-${PV}.tar.bz2"
 
 inherit autotools pkgconfig
 
-do_stage() {
-        oe_libinstall -a -so -C libexif libexif ${STAGING_LIBDIR}
+do_configure_append() {
+       sed -i s:doc\ binary:binary:g Makefile
+}
 
-        install -d ${STAGING_INCDIR}/libexif
-        for X in exif-byte-order.h exif-data.h exif-format.h exif-loader.h exif-tag.h exif-content.h exif-entry.h exif-ifd.h exif-utils.h exif-log.h exif-mnote-data.h _stdint.h exif-data-type.h exif-mem.h
-        do
-                install -m 0644 ${S}/libexif/$X ${STAGING_INCDIR}/libexif/$X
-        done
+do_stage() {
+       autotools_stage_all
 }