omap3517-evm: omap3517 was the pre-production name, AM3517 is the production name...
authorKoen Kooi <k-kooi@ti.com>
Thu, 29 Oct 2009 13:52:47 +0000 (14:52 +0100)
committerKoen Kooi <koen@openembedded.org>
Thu, 29 Oct 2009 14:25:38 +0000 (15:25 +0100)
Signed-off-by: Koen Kooi <k-kooi@ti.com>
conf/machine/am3517-evm.conf [moved from conf/machine/omap3517-evm.conf with 97% similarity]
contrib/angstrom/sort.sh
recipes/clutter/clutter.inc
recipes/linux/linux-omap-psp-2.6.29/am3517-evm/defconfig [moved from recipes/linux/linux-omap-psp-2.6.29/omap3517-evm/defconfig with 100% similarity]
recipes/linux/linux-omap-psp/am3517-evm/defconfig [moved from recipes/linux/linux-omap-psp/omap3517-evm/defconfig with 100% similarity]
recipes/linux/linux-omap-psp_2.6.29.bb
recipes/linux/linux-omap-psp_2.6.31.bb
recipes/u-boot/u-boot_git.bb
recipes/x-load/x-load_1.41.bb
recipes/x-load/x-load_git.bb
recipes/xorg-xserver/xserver-xorg-conf/am3517-evm/xorg.conf [moved from recipes/xorg-xserver/xserver-xorg-conf/omap3517-evm/xorg.conf with 100% similarity]

similarity index 97%
rename from conf/machine/omap3517-evm.conf
rename to conf/machine/am3517-evm.conf
index 77ea280..f7a60b4 100644 (file)
@@ -15,6 +15,8 @@ GUI_MACHINE_CLASS = "smallscreen"
 
 require conf/machine/include/omap3.inc
 
+PACKAGE_EXTRA_ARCHS += "omap3517-evm"
+
 # Ship all kernel modules
 MACHINE_EXTRA_RRECOMMENDS = " omap3-sgx-modules kernel-modules"
 
index c8b1d76..1e787a4 100755 (executable)
@@ -58,7 +58,7 @@ case "$arch" in
        "armv7")
                        machines="" ;;
        "armv7a")
-                       machines="igep0020 omap3-touchbook beagleboard omap3evm omap3517-evm omap3-pandora omapzoom omapzoom2 overo" ;;
+                       machines="igep0020 omap3-touchbook beagleboard omap3evm am3517-evm omap3517-evm omap3-pandora omapzoom omapzoom2 overo" ;;
        "avr32")
                        machines="atngw100 at32stk1000" ;;
        "bfin")
index 705cece..55980ed 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Clutter graphics library"
 HOMEPAGE = "http://www.clutter-project.org/"
 LICENSE = "LGPL"
 
-COMPATIBLE_MACHINE = "(zylonite|mx31litekit|omap-3430ldp|omap-3430sdp|mx31ads|qemuarm|qemux86|ipodtouch|omap3517-evm|beagleboard|overo|omap3evm|omap5912osk)"
+COMPATIBLE_MACHINE = "(zylonite|mx31litekit|omap-3430ldp|omap-3430sdp|mx31ads|qemuarm|qemux86|ipodtouch|am3517-evm|beagleboard|overo|omap3evm|omap5912osk)"
 
 STDDEPENDS = "virtual/libx11 gtk-doc-native pango glib-2.0 libxfixes gtk+"
 BASE_CONF = "--disable-gtk-doc ${@get_clutter_fpu_setting(bb, d)}"
index 4c213b1..2a2754e 100644 (file)
@@ -3,7 +3,7 @@ require linux.inc
 DESCRIPTION = "Linux kernel for OMAP processors"
 KERNEL_IMAGETYPE = "uImage"
 
-COMPATIBLE_MACHINE = "omap3evm|omap3517-evm"
+COMPATIBLE_MACHINE = "omap3evm|am3517-evm"
 
 SRCREV = "9abb6eb717acbca192ab251a056e3a66b2b47884"
 
@@ -16,7 +16,7 @@ SRC_URI = "git://arago-project.org/git/people/sriram/ti-psp-omap.git;protocol=gi
 
 S = "${WORKDIR}/git"
 
-SRC_URI_append_omap3517-evm = " \
+SRC_URI_append_am3517-evm = " \
         file://shiva-bits.diff;patch=1 \
         file://shiva-ehci.diff;patch=1 \
 "
index 6828d52..1e931e1 100644 (file)
@@ -3,7 +3,7 @@ require linux.inc
 DESCRIPTION = "Linux kernel for OMAP processors"
 KERNEL_IMAGETYPE = "uImage"
 
-COMPATIBLE_MACHINE = "omap3evm|omap3517-evm"
+COMPATIBLE_MACHINE = "omap3evm|am3517-evm"
 
 SRCREV = "9cf7a18fe227717dcc08163100dacd579de48e0c"
 
index 3d067c9..15c3060 100644 (file)
@@ -47,8 +47,8 @@ SRCREV_omap3evm = "2dea1db2a3b7c12ed70bbf8ee50755089c5e5170"
 PV_omap3evm = "2009.03+${PR}+gitr${SRCREV}"
 
 
-SRCREV_omap3517-evm = "e60beb13cf0"
-SRC_URI_append_omap3517-evm = " \
+SRCREV_am3517-evm = "e60beb13cf0"
+SRC_URI_append_am3517-evm = " \
 file://omap3evm/0001-Changes-for-making-a-NAND-build.patch;patch=1 \
 file://omap3evm/0002-Fix-for-NFS-boot-for-OMAP3-EVM.patch;patch=1 \
 file://omap3evm/0003-OMAP3-timer-handling-to-1ms-tick-and-CONFIG_SYS_HZ-t.patch;patch=1 \
@@ -66,7 +66,7 @@ file://omap3evm/0014-EMAC-driver-cleanup-removed-debug-prints.patch;patch=1 \
 file://omap3evm/0015-EMAC-driver-Check-for-link-status-in-packet-send-lo.patch;patch=1 \
 file://omap3evm/0016-Config-option-and-name-changed-to-omap3517_evm.patch;patch=1 \
 "
-PV_omap3517-evm = "2009.03+${PR}+gitr${SRCREV}"
+PV_am3517-evm = "2009.03+${PR}+gitr${SRCREV}"
 
 SRC_URI_omapzoom = "git://www.sakoman.net/git/u-boot-omap3.git;branch=omap3-dev;protocol=git"
 SRCREV_omapzoom = "d691b424f1f5bf7eea3a4131dfc578d272e8f335"
index 0a38f5b..6995e66 100644 (file)
@@ -1,6 +1,6 @@
 require x-load.inc
 
-COMPATIBLE_MACHINE = "omap3517-evm"
+COMPATIBLE_MACHINE = "am3517-evm"
 
 SRC_URI = "file://x-loader-03.00.00.01.tar.gz \
 file://0013-board.c-print-boot-method-mmc-onenand-nand.patch;patch=1 \
index 3368fce..0e0e603 100644 (file)
@@ -1,6 +1,6 @@
 require x-load.inc
 
-DEFAULT_PREFERENCE_omap3517-evm = "-1"
+DEFAULT_PREFERENCE_am3517-evm = "-1"
 DEFAULT_PREFERENCE_omap3-pandora = "-1"
 
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/x-load-git/${MACHINE}"
@@ -23,7 +23,7 @@ SRC_URI_append_omap3-touchbook = " \
                              "
 
 
-SRC_URI_append_omap3517-evm = " \
+SRC_URI_append_am3517-evm = " \
                                  file://xload-shiva.diff;patch=1 \
 "