eglibc: Backport IO-acquire-lock-fix.patch
authorKhem Raj <raj.khem@gmail.com>
Fri, 30 Oct 2009 20:00:14 +0000 (13:00 -0700)
committerKhem Raj <raj.khem@gmail.com>
Fri, 30 Oct 2009 20:00:14 +0000 (13:00 -0700)
* Move the svn recipe to latest git revision.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
recipes/eglibc/eglibc_2.10.bb
recipes/eglibc/eglibc_2.9.bb
recipes/eglibc/eglibc_svn.bb
recipes/eglibc/files/IO-acquire-lock-fix.patch [new file with mode: 0644]

index 1bd3d6e..d143b0a 100644 (file)
@@ -3,12 +3,13 @@ require eglibc.inc
 DEPENDS += "gperf-native"
 FILESPATHPKG =. "eglibc-svn:"
 PV = "2.10"
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.4"
 SVN_REV="9124"
 EGLIBC_BRANCH="eglibc-2_10"
 SRC_URI = "svn://svn.eglibc.org/branches;module=eglibc-2_10;rev=${SVN_REV};proto=svn \
            file://eglibc-svn-arm-lowlevellock-include-tls.patch;patch=1 \
            file://armv4t-interworking.patch;patch=1 \
+           file://IO-acquire-lock-fix.patch;patch=1 \
            file://etc/ld.so.conf \
            file://generate-supported.mk"
 S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
index 6b27745..3efcb36 100644 (file)
@@ -3,12 +3,13 @@ require eglibc.inc
 DEPENDS += "gperf-native"
 FILESPATHPKG =. "eglibc-svn:"
 PV = "2.9"
-PR = "${INC_PR}.4"
+PR = "${INC_PR}.5"
 SVN_REV="8690"
 EGLIBC_BRANCH="eglibc-2_9"
 SRC_URI = "svn://svn.eglibc.org/branches;module=eglibc-2_9;rev=${SVN_REV};proto=svn \
            file://eglibc-svn-arm-lowlevellock-include-tls.patch;patch=1 \
           file://armv4t-interworking.patch;patch=1 \
+          file://IO-acquire-lock-fix.patch;patch=1 \
            file://etc/ld.so.conf \
            file://generate-supported.mk"
 S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
index 1988350..1a91af8 100644 (file)
@@ -1,7 +1,7 @@
 require eglibc.inc
 
 DEPENDS += "gperf-native"
-SRCREV = "9123"
+SRCREV = "9170"
 DEFAULT_PREFERENCE = "-1"
 FILESPATHPKG =. "eglibc-svn:"
 PV = "2.10+svnr${SRCREV}"
@@ -10,6 +10,7 @@ EGLIBC_BRANCH="trunk"
 SRC_URI = "svn://svn.eglibc.org;module=trunk \
            file://eglibc-svn-arm-lowlevellock-include-tls.patch;patch=1 \
           file://armv4t-interworking.patch;patch=1 \
+          file://IO-acquire-lock-fix.patch;patch=1 \
            file://etc/ld.so.conf \
            file://generate-supported.mk"
 S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
diff --git a/recipes/eglibc/files/IO-acquire-lock-fix.patch b/recipes/eglibc/files/IO-acquire-lock-fix.patch
new file mode 100644 (file)
index 0000000..4d3e061
--- /dev/null
@@ -0,0 +1,15 @@
+import http://sourceware.org/ml/libc-ports/2007-12/msg00000.html
+
+Index: libc/bits/stdio-lock.h
+===================================================================
+--- libc.orig/bits/stdio-lock.h        2009-10-28 14:34:19.000000000 -0700
++++ libc/bits/stdio-lock.h     2009-10-28 14:34:54.000000000 -0700
+@@ -50,6 +50,8 @@ __libc_lock_define_recursive (typedef, _
+   _IO_cleanup_region_start ((void (*) (void *)) _IO_funlockfile, (_fp));      \
+   _IO_flockfile (_fp)
++# define _IO_acquire_lock_clear_flags2(_fp) _IO_acquire_lock (_fp)
++
+ # define _IO_release_lock(_fp) \
+   _IO_funlockfile (_fp);                                                    \
+   _IO_cleanup_region_end (0)