network-manager: fix 0.7.9999
authorKoen Kooi <koen@openembedded.org>
Mon, 15 Feb 2010 20:05:26 +0000 (21:05 +0100)
committerKoen Kooi <koen@openembedded.org>
Wed, 17 Feb 2010 08:43:41 +0000 (09:43 +0100)
recipes/networkmanager/networkmanager-0.7.inc
recipes/networkmanager/networkmanager_0.7.999.bb

index 3494aa7..91c9190 100644 (file)
@@ -28,7 +28,7 @@ do_stage () {
 # Work around dbus permission problems since we lack a proper at_console
 do_install_prepend() {
                sed -i -e s:deny:allow:g ${S}/src/NetworkManager.conf
-               sed -i -e s:deny:allow:g ${S}/system-settings/src/nm-system-settings.conf
+               sed -i -e s:deny:allow:g ${S}/system-settings/src/nm-system-settings.conf || true
                sed -i -e s:deny:allow:g ${S}/callouts/nm-dispatcher.conf
 }
 
@@ -38,7 +38,7 @@ do_install_append () {
         # Test binaries
         install -d ${D}/usr/bin
         install -m 0755 ${S}/test/.libs/nm-tool ${D}/usr/bin
-        install -m 0755 ${S}/test/.libs/libnm_glib_test ${D}/usr/bin
+        install -m 0755 ${S}/test/.libs/libnm* ${D}/usr/bin
         install -m 0755 ${S}/test/.libs/nm-online ${D}/usr/bin
 }
 
index 2cf0770..4d9c533 100644 (file)
@@ -2,7 +2,7 @@ require networkmanager-0.7.inc
 
 DEFAULT_PREFERENCE = "-1"
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI += " \
     file://remove-gtk-doc-make.patch;patch=1 \
@@ -19,6 +19,7 @@ do_configure_prepend() {
     sed -i -e /^docs/d ${S}/configure.ac
 }
 
+FILES_${PN} += "  ${datadir}/polkit-1/"
 
 S = "${WORKDIR}/NetworkManager-${PV}"