packages/initscripts/initscripts_1.0.bb:Add mountall.sh script for oplinux-uclibc
authorStelios Koroneos <skoroneos@digital-opsis.com>
Wed, 2 May 2007 15:20:30 +0000 (15:20 +0000)
committerStelios Koroneos <skoroneos@digital-opsis.com>
Wed, 2 May 2007 15:20:30 +0000 (15:20 +0000)
packages/initscripts/initscripts-1.0/oplinux-uclibc/mountall.sh [new file with mode: 0755]
packages/initscripts/initscripts_1.0.bb

diff --git a/packages/initscripts/initscripts-1.0/oplinux-uclibc/mountall.sh b/packages/initscripts/initscripts-1.0/oplinux-uclibc/mountall.sh
new file mode 100755 (executable)
index 0000000..33d7065
--- /dev/null
@@ -0,0 +1,45 @@
+#
+# mountall.sh  Mount all filesystems.
+#
+# Version:     @(#)mountall.sh  2.83-2  01-Nov-2001  miquels@cistron.nl
+#
+. /etc/default/rcS
+
+#
+# Mount local filesystems in /etc/fstab. For some reason, people
+# might want to mount "proc" several times, and mount -v complains
+# about this. So we mount "proc" filesystems without -v.
+#
+test "$VERBOSE" != no && echo "Mounting local filesystems..."
+mount -a 2>/dev/null
+
+#
+# We might have mounted something over /dev, see if /dev/initctl is there.
+#
+if test ! -p /dev/initctl
+then
+       rm -f /dev/initctl
+       mknod -m 600 /dev/initctl p
+fi
+kill -USR1 1
+
+#
+# Execute swapon command again, in case we want to swap to
+# a file on a now mounted filesystem.
+#
+doswap=yes
+case "`uname -r`" in
+       2.[0123].*)
+               if grep -qs resync /proc/mdstat
+               then
+                       doswap=no
+               fi
+               ;;
+esac
+if test $doswap = yes
+then
+       swapon -a 2> /dev/null
+fi
+
+: exit 0
+
index 4409c30..21e3bb2 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "required"
 DEPENDS = "makedevs"
 RDEPENDS = "makedevs"
 LICENSE = "GPL"
-PR = "r89"
+PR = "r90"
 
 SRC_URI = "file://halt \
            file://ramdisk \