ftpd-topfield: Updated to 0.7.5 and added the syslog patch
authorRod Whitby <rod@whitby.id.au>
Fri, 28 Mar 2008 03:55:03 +0000 (03:55 +0000)
committerRod Whitby <rod@whitby.id.au>
Fri, 28 Mar 2008 03:55:03 +0000 (03:55 +0000)
packages/ftpd-topfield/files/syslog.patch [new file with mode: 0644]
packages/ftpd-topfield/ftpd-topfield_0.7.5.bb [moved from packages/ftpd-topfield/ftpd-topfield_0.7.4.bb with 84% similarity]

diff --git a/packages/ftpd-topfield/files/syslog.patch b/packages/ftpd-topfield/files/syslog.patch
new file mode 100644 (file)
index 0000000..8c2bf29
--- /dev/null
@@ -0,0 +1,26 @@
+--- ftpd-topfield/ftpd.c~      2008-02-16 09:49:30.000000000 +1030
++++ ftpd-topfield/ftpd.c       2008-03-24 21:45:15.000000000 +1030
+@@ -1190,6 +1190,7 @@
+               if (debug) {
+                       fprintf(stderr, "Transfer failed %lld bytes %s\n", (long long)current, srcpath);
+               }
++              syslog(LOG_INFO, "retrieve: Failed transfer of %s @%Ld", srcpath, (long long)current);
+               perror_reply (550, name);
+       }
+@@ -1363,6 +1364,7 @@
+ #endif
+       if (ret != 0) {
++              syslog(LOG_INFO, "store: Failed transfer of %s @%Ld", destpath, (long long)current);
+               perror_reply (553, name);
+               LOGCMD (*mode == 'w' ? "put" : "append", name);
+@@ -1451,6 +1453,7 @@
+                               }
+                       }
++                      syslog(LOG_INFO, "store: Failed transfer of %s @%Ld", destpath, (long long)current);
+                       /* Failed to cancel the put, so give up */
+                       perror_reply (426, "Data Connection");
+               }
similarity index 84%
rename from packages/ftpd-topfield/ftpd-topfield_0.7.4.bb
rename to packages/ftpd-topfield/ftpd-topfield_0.7.5.bb
index 356a601..74a3743 100755 (executable)
@@ -3,9 +3,11 @@ DESCRIPTION = "ftpd-topfield - FTP access to TopField PVR"
 HOMEPAGE = "http://sourceforge.net/projects/puppy"
 SECTION = "net"
 LICENSE = "MIT"
+PR = "r1"
 
-SRC_URI = "cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=ftpd-topfield;tag=FTPD_TOPFIELD_0_7_4 \
-          cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=libtopfield;tag=FTPD_TOPFIELD_0_7_4 \
+SRC_URI = "cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=ftpd-topfield;tag=FTPD_TOPFIELD_0_7_5 \
+          cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=libtopfield;tag=FTPD_TOPFIELD_0_7_5 \
+          file://syslog.patch;patch=1 \
           file://init"
 
 # The source will end up in the subdirectory 'ftpd-topfield' - no release name