- add curl-native
authorMichael Lauer <mickey@vanille-media.de>
Mon, 8 Aug 2005 12:09:11 +0000 (12:09 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Mon, 8 Aug 2005 12:09:11 +0000 (12:09 +0000)
- explicitly disable libidn support

packages/curl/curl-native_7.14.0.bb [new file with mode: 0644]
packages/curl/curl_7.14.0.bb

diff --git a/packages/curl/curl-native_7.14.0.bb b/packages/curl/curl-native_7.14.0.bb
new file mode 100644 (file)
index 0000000..7b99c7c
--- /dev/null
@@ -0,0 +1,3 @@
+include curl_${PV}.bb
+inherit native
+
index 1b8a88d..609320c 100644 (file)
@@ -1,31 +1,23 @@
-# NOTE: FIXME: curl puts its LDFLAGS in its curl-config and curl.pc files.
-# This is flawed, as the LDFLAGS are often overridden by the user, and in
-# addition, are generally specific to the *build* environment, not target.
-# curl's build should be fixed to manipulate LIBS where appropriate and
-# use that. -CL
-
-DESCRIPTION = "Command line tool and library for \
-client-side URL transfers."
-LICENSE = "MIT" 
+DESCRIPTION = "Command line tool and library for client-side URL transfers."
+LICENSE = "MIT"
 DEPENDS = "zlib"
 SECTION = "console/network"
-PR = "r0"
+PR = "r2"
 
 SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2"
+S = "${WORKDIR}/curl-${PV}"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig binconfig
 
 EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
-               --without-ssl --with-random=/dev/urandom"
+               --without-ssl \
+               --with-random=/dev/urandom \
+               --without-idn"
 
 do_stage () {
        install -d ${STAGING_INCDIR}/curl
        install -m 0644 ${S}/include/curl/*.h ${STAGING_INCDIR}/curl/
        oe_libinstall -so -a -C lib libcurl ${STAGING_LIBDIR}
-
-       cat curl-config | sed -e "s,-I/usr/include,-I${STAGING_INCDIR}/," \
-                        | sed -e "s,-L/usr/lib , , "> ${STAGING_BINDIR}/curl-config
-        chmod a+rx ${STAGING_BINDIR}/curl-config
 }
 
 PACKAGES = "curl curl-doc libcurl libcurl-dev libcurl-doc"